summaryrefslogtreecommitdiffstats
path: root/build
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2008-10-21 16:01:02 +0200
committerSamuel Ortiz <sameo@openedhand.com>2008-10-21 16:01:02 +0200
commite5c53ce035eb36fc1b416e9971582a45754844be (patch)
tree4d14d39f2e5f5c4a371a17563155b3f6bd2f0e93 /build
parent3e045793c740cbac302c2077cc839f1a64c03bc2 (diff)
downloadopenembedded-core-e5c53ce035eb36fc1b416e9971582a45754844be.tar.gz
netbook: changed platform name from eee901 to netbook
We want to have a more generic platform definition. The netbook machine one currently supports the eee901 and the aspire one. We also moved the machine and netbook image definitions to meta-moblin.
Diffstat (limited to 'build')
-rw-r--r--build/conf/local.conf.sample26
1 files changed, 19 insertions, 7 deletions
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index 619dccabbc..478dac9ad0 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -1,6 +1,15 @@
# Where to cache the files Poky downloads
DL_DIR ?= "${OEROOT}/sources"
-BBFILES = "${OEROOT}/meta/packages/*/*.bb"
+BBFILES = "\
+ ${OEROOT}/meta/packages/*/*.bb \
+ ${OEROOT}/meta-moblin/packages/*/*.bb"
+
+BBFILE_COLLECTIONS = "normal moblin"
+BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
+BBFILE_PATTERN_moblin = "^${OEROOT}/meta-moblin/"
+
+BBFILE_PRIORITY_normal = "5"
+BBFILE_PRIORITY_moblin = "5"
# Uncomment and set to allow bitbake to execute multiple tasks at once.
# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
@@ -10,11 +19,11 @@ BBFILES = "${OEROOT}/meta/packages/*/*.bb"
# PARALLEL_MAKE = "-j 4"
# The machine to target
-MACHINE ?= "qemuarm"
+MACHINE ?= "netbook"
# Other supported machines
#MACHINE ?= "qemux86"
-#MACHINE ?= "eee901"
+#MACHINE ?= "qemuarm"
#MACHINE ?= "c7x0"
#MACHINE ?= "akita"
#MACHINE ?= "spitz"
@@ -37,17 +46,20 @@ DISTRO ?= "poky"
# Poky has various extra metadata collections (openmoko, extras).
# To enable these, uncomment all (or some of) the following lines:
# BBFILES = "\
-# ${OEROOT}/meta/packages/*/*.bb
-# ${OEROOT}/meta-extras/packages/*/*.bb
-# ${OEROOT}/meta-openmoko/packages/*/*.bb
+# ${OEROOT}/meta/packages/*/*.bb \
+# ${OEROOT}/meta-extras/packages/*/*.bb \
+# ${OEROOT}/meta-openmoko/packages/*/*.bb \
+# ${OEROOT}/meta-moblin/packages/*/*.bb \
# "
-# BBFILE_COLLECTIONS = "normal extras openmoko"
+# BBFILE_COLLECTIONS = "normal extras openmoko moblin"
# BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
# BBFILE_PATTERN_extras = "^${OEROOT}/meta-extras/"
# BBFILE_PATTERN_openmoko = "^${OEROOT}/meta-openmoko/"
+# BBFILE_PATTERN_moblin = "^${OEROOT}/meta-moblin/"
# BBFILE_PRIORITY_normal = "5"
# BBFILE_PRIORITY_extras = "5"
# BBFILE_PRIORITY_openmoko = "5"
+# BBFILE_PRIORITY_moblin = "5"
BBMASK = ""