summaryrefslogtreecommitdiffstats
path: root/build
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-07-21 14:55:39 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 15:39:53 +0100
commit971907567cff64e74f21d349d6751dadc8c09827 (patch)
treee0cfd7ee0ba3091272eca5c5f1b90edffc3653aa /build
parent50629b3746c149b22bdd8664842a4c69abb2b989 (diff)
downloadopenembedded-core-971907567cff64e74f21d349d6751dadc8c09827.tar.gz
Enable build dir outside of the poky directory
You need to first set up the build directory by sourcing the poky build script, after that builds can be run in that directory so long as bitbake is in $PATH removing the need to source the init script for each build. i.e: $ . poky-init-build-env ~/my-build $ bitbake some-image <<later, in a different shell>> $ cd ~/my-build $ export PATH=/path/to/bitbake/bin:$PATH $ bitbake an-image This patch also removes use of OEROOT in recipes, etc. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'build')
-rw-r--r--build/conf/bblayers.conf.sample4
-rw-r--r--build/conf/local.conf.sample20
-rw-r--r--build/conf/site.conf.sample4
3 files changed, 5 insertions, 23 deletions
diff --git a/build/conf/bblayers.conf.sample b/build/conf/bblayers.conf.sample
index dff44e49c4..04b7768ffa 100644
--- a/build/conf/bblayers.conf.sample
+++ b/build/conf/bblayers.conf.sample
@@ -4,6 +4,6 @@ LCONF_VERSION = "1"
BBFILES ?= ""
BBLAYERS = " \
- ${OEROOT}/meta \
- ${OEROOT}/meta-moblin \
+ ##POKYBASE##/meta \
+ ##POKYBASE##/meta-moblin \
"
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index 32bd409ecc..78c3bd144e 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -42,24 +42,6 @@ DISTRO ?= "poky"
# For bleeding edge / experimental / unstable package versions
# DISTRO ?= "poky-bleeding"
-# Poky has various extra metadata collections (openmoko, extras).
-# To enable these, uncomment all (or some of) the following lines:
-# BBFILES = "\
-# ${OEROOT}/meta/packages/*/*.bb \
-# ${OEROOT}/meta-extras/packages/*/*.bb \
-# ${OEROOT}/meta-openmoko/packages/*/*.bb \
-# ${OEROOT}/meta-moblin/packages/*/*.bb \
-# "
-# BBFILE_COLLECTIONS = "normal extras openmoko moblin"
-# BBFILE_PATTERN_normal = "^${OEROOT}/meta/"
-# BBFILE_PATTERN_extras = "^${OEROOT}/meta-extras/"
-# BBFILE_PATTERN_openmoko = "^${OEROOT}/meta-openmoko/"
-# BBFILE_PATTERN_moblin = "^${OEROOT}/meta-moblin/"
-# BBFILE_PRIORITY_normal = "5"
-# BBFILE_PRIORITY_extras = "5"
-# BBFILE_PRIORITY_openmoko = "5"
-# BBFILE_PRIORITY_moblin = "5"
-
BBMASK = ""
# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
@@ -109,7 +91,7 @@ PACKAGE_CLASSES ?= "package_ipk"
# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
# disk space, so make sure to free enough space. The default TMPDIR is
# <build directory>/tmp
-TMPDIR = "${OEROOT}/build/tmp"
+#TMPDIR = "${POKYBASE}/build/tmp"
# Uncomment this if you are using the Openedhand provided qemu deb - see README
diff --git a/build/conf/site.conf.sample b/build/conf/site.conf.sample
index 060dca087c..42042042f7 100644
--- a/build/conf/site.conf.sample
+++ b/build/conf/site.conf.sample
@@ -20,7 +20,7 @@ SCONF_VERSION = "1"
# although this only works for http
#GIT_PROXY_HOST = "proxy.example.com"
#GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${OEROOT}/scripts/poky-git-proxy-command"
+#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-command"
# GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
#GIT_CORE_CONFIG = "Yes"
@@ -32,7 +32,7 @@ SCONF_VERSION = "1"
# and then share that binary somewhere in PATH, then use the following settings
#GIT_PROXY_HOST = "proxy.example.com"
#GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${OEROOT}/scripts/poky-git-proxy-socks-command"
+#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-socks-command"
# Uncomment this to use a shared download directory