summaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-06-10 08:56:40 +0000
committerRichard Purdie <richard@openedhand.com>2006-06-10 08:56:40 +0000
commitbc8ad1b1cda0dd21b5b0b816b386b0bf96d5891a (patch)
treeaff958d279429942895c02807bf5da84d77cf5c7 /bitbake
parent65cef0da326e839871f21f638bdfc7fda17e4654 (diff)
downloadopenembedded-core-bc8ad1b1cda0dd21b5b0b816b386b0bf96d5891a.tar.gz
bitbake: Update against upstream stable branch (includes srcdate='now' support)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@458 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake')
-rwxr-xr-xbitbake/bin/bitbake16
-rw-r--r--bitbake/doc/manual/usermanual.xml8
-rw-r--r--bitbake/lib/bb/fetch/__init__.py22
-rw-r--r--bitbake/lib/bb/fetch/cvs.py8
-rw-r--r--bitbake/lib/bb/fetch/svk.py4
-rw-r--r--bitbake/lib/bb/fetch/svn.py11
6 files changed, 44 insertions, 25 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 10cf4bd00a..7fbe7ed5eb 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -781,11 +781,19 @@ class BBCooker:
try:
self.configuration.data = bb.parse.handle( afile, self.configuration.data )
- # Add the handlers we inherited by INHERITS
+ # Add the handlers we inherited by INHERIT
+ # we need to do this manually as it is not guranteed
+ # we will pick up these classes... as we only INHERIT
+ # on .inc and .bb files but not on .conf
+ data = bb.data.createCopy( self.configuration.data )
+ inherits = ["base"] + (bb.data.getVar('INHERIT', data, True ) or "").split()
+ for inherit in inherits:
+ data = bb.parse.handle( os.path.join('classes', '%s.bbclass' % inherit ), data, True )
+
# FIXME: This assumes that we included at least one .inc file
- for var in bb.data.keys(self.configuration.data):
- if bb.data.getVarFlag(var, 'handler', self.configuration.data):
- bb.event.register(var,bb.data.getVar(var,self.configuration.data))
+ for var in bb.data.keys(data):
+ if bb.data.getVarFlag(var, 'handler', data):
+ bb.event.register(var,bb.data.getVar(var, data))
except IOError:
bb.fatal( "Unable to open %s" % afile )
diff --git a/bitbake/doc/manual/usermanual.xml b/bitbake/doc/manual/usermanual.xml
index 33150b10f2..c314236c6f 100644
--- a/bitbake/doc/manual/usermanual.xml
+++ b/bitbake/doc/manual/usermanual.xml
@@ -250,9 +250,9 @@ a per URI parameters separated by a <quote>;</quote> consisting of a key and a v
<section>
<title>CVS File Fetcher</title>
- <para>The URN for the CVS Fetcher is <emphasis>cvs</emphasis>. This Fetcher honors the variables <varname>DL_DIR</varname>, <varname>SRCDATE</varname>, <varname>FETCHCOMMAND_cvs</varname>, <varname>UPDATECOMMAND_cvs</varname>. <varname>DL_DIRS</varname> specifies where a temporary checkout is saved, <varname>SRCDATE</varname> specifies which date to use when doing the fetching, <varname>FETCHCOMMAND</varname> and <varname>UPDATECOMMAND</varname> specify which executables should be used when doing the CVS checkout or update.
+ <para>The URN for the CVS Fetcher is <emphasis>cvs</emphasis>. This Fetcher honors the variables <varname>DL_DIR</varname>, <varname>SRCDATE</varname>, <varname>FETCHCOMMAND_cvs</varname>, <varname>UPDATECOMMAND_cvs</varname>. <varname>DL_DIRS</varname> specifies where a temporary checkout is saved, <varname>SRCDATE</varname> specifies which date to use when doing the fetching (the special value of "now" will cause the checkout to be updated on every build), <varname>FETCHCOMMAND</varname> and <varname>UPDATECOMMAND</varname> specify which executables should be used when doing the CVS checkout or update.
</para>
- <para>The supported Parameters are <varname>module</varname>, <varname>tag</varname>, <varname>date</varname>, <varname>method</varname>, <varname>localdir</varname>, <varname>rsh</varname>. The <varname>module</varname> specifies which module to check out, the <varname>tag</varname> describes which CVS TAG should be used for the checkout by default the TAG is empty. A <varname>date</varname> can be specified to override the SRCDATE of the configuration to checkout a specific date. <varname>method</varname> is by default <emphasis>pserver</emphasis>, if <emphasis>ext</emphasis> is used the <varname>rsh</varname> parameter will be evaluated and <varname>CVS_RSH</varname> will be set. Finally <varname>localdir</varname> is used to checkout into a special directory relative to <varname>CVSDIR></varname>.
+ <para>The supported Parameters are <varname>module</varname>, <varname>tag</varname>, <varname>date</varname>, <varname>method</varname>, <varname>localdir</varname>, <varname>rsh</varname>. The <varname>module</varname> specifies which module to check out, the <varname>tag</varname> describes which CVS TAG should be used for the checkout by default the TAG is empty. A <varname>date</varname> can be specified to override the SRCDATE of the configuration to checkout a specific date. The special value of "now" will cause the checkout to be updated on every build.<varname>method</varname> is by default <emphasis>pserver</emphasis>, if <emphasis>ext</emphasis> is used the <varname>rsh</varname> parameter will be evaluated and <varname>CVS_RSH</varname> will be set. Finally <varname>localdir</varname> is used to checkout into a special directory relative to <varname>CVSDIR></varname>.
<screen><varname>SRC_URI</varname> = "cvs://CVSROOT;module=mymodule;tag=some-version;method=ext"
<varname>SRC_URI</varname> = "cvs://CVSROOT;module=mymodule;date=20060126;localdir=usethat"
</screen>
@@ -275,7 +275,7 @@ will be tried first when fetching a file if that fails the actual file will be t
<section>
<title>SVK Fetcher</title>
<para>
- <emphasis>Currently NOT suppoered</emphasis>
+ <emphasis>Currently NOT supported</emphasis>
</para>
</section>
@@ -283,7 +283,7 @@ will be tried first when fetching a file if that fails the actual file will be t
<title>SVN Fetcher</title>
<para>The URN for the SVN Fetcher is <emphasis>svn</emphasis>.
</para>
- <para>The Variables <varname>FETCHCOMMAND_svn</varname>, <varname>DL_DIR</varname> are used by the SVN Fetcher. <varname>FETCHCOMMAND</varname> contains the subversion command, <varname>DL_DIR</varname> is the directory where tarballs will be saved.
+ <para>This Fetcher honors the variables <varname>FETCHCOMMAND_svn</varname>, <varname>DL_DIR</varname>, <varname>SRCDATE</varname>. <varname>FETCHCOMMAND</varname> contains the subversion command, <varname>DL_DIR</varname> is the directory where tarballs will be saved, <varname>SRCDATE</varname> specifies which date to use when doing the fetching (the special value of "now" will cause the checkout to be updated on every build).
</para>
<para>The supported Parameters are <varname>proto</varname>, <varname>rev</varname>. <varname>proto</varname> is the subversion prototype, <varname>rev</varname> is the subversions revision.
</para>
diff --git a/bitbake/lib/bb/fetch/__init__.py b/bitbake/lib/bb/fetch/__init__.py
index ac698a0d1c..a2defd25a5 100644
--- a/bitbake/lib/bb/fetch/__init__.py
+++ b/bitbake/lib/bb/fetch/__init__.py
@@ -185,6 +185,28 @@ class Fetch(object):
return False
try_mirror = staticmethod(try_mirror)
+ def check_for_tarball(d, tarfn, dldir, date):
+ """
+ Check for a local copy then check the tarball stash.
+ Both checks are skipped if date == 'now'.
+
+ d Is a bb.data instance
+ tarfn is the name of the tarball
+ date is the SRCDATE
+ """
+ if "now" != date:
+ dl = os.path.join(dldir, tarfn)
+ if os.access(dl, os.R_OK):
+ bb.debug(1, "%s already exists, skipping checkout." % tarfn)
+ return True
+
+ # try to use the tarball stash
+ if Fetch.try_mirror(d, tarfn):
+ return True
+ return False
+ check_for_tarball = staticmethod(check_for_tarball)
+
+
import cvs
import git
import local
diff --git a/bitbake/lib/bb/fetch/cvs.py b/bitbake/lib/bb/fetch/cvs.py
index 10ec700dc9..0b2477560a 100644
--- a/bitbake/lib/bb/fetch/cvs.py
+++ b/bitbake/lib/bb/fetch/cvs.py
@@ -128,13 +128,7 @@ class Cvs(Fetch):
data.setVar('TARFILES', dlfile, localdata)
data.setVar('TARFN', tarfn, localdata)
- dl = os.path.join(dldir, tarfn)
- if os.access(dl, os.R_OK):
- bb.debug(1, "%s already exists, skipping cvs checkout." % tarfn)
- continue
-
- # try to use the tarball stash
- if Fetch.try_mirror(d, tarfn):
+ if Fetch.check_for_tarball(d, tarfn, dldir, date):
continue
if date:
diff --git a/bitbake/lib/bb/fetch/svk.py b/bitbake/lib/bb/fetch/svk.py
index c0819da3dc..19103213cd 100644
--- a/bitbake/lib/bb/fetch/svk.py
+++ b/bitbake/lib/bb/fetch/svk.py
@@ -101,9 +101,7 @@ class Svk(Fetch):
data.setVar('TARFILES', dlfile, localdata)
data.setVar('TARFN', tarfn, localdata)
- dl = os.path.join(dldir, tarfn)
- if os.access(dl, os.R_OK):
- bb.debug(1, "%s already exists, skipping svk checkout." % tarfn)
+ if Fetch.check_for_tarball(d, tarfn, dldir, date):
continue
olddir = os.path.abspath(os.getcwd())
diff --git a/bitbake/lib/bb/fetch/svn.py b/bitbake/lib/bb/fetch/svn.py
index 6e3a9277ab..d1a959371b 100644
--- a/bitbake/lib/bb/fetch/svn.py
+++ b/bitbake/lib/bb/fetch/svn.py
@@ -111,13 +111,7 @@ class Svn(Fetch):
data.setVar('TARFILES', dlfile, localdata)
data.setVar('TARFN', tarfn, localdata)
- dl = os.path.join(dldir, tarfn)
- if os.access(dl, os.R_OK):
- bb.debug(1, "%s already exists, skipping svn checkout." % tarfn)
- continue
-
- # try to use the tarball stash
- if Fetch.try_mirror(d, tarfn):
+ if Fetch.check_for_tarball(d, tarfn, dldir, date):
continue
olddir = os.path.abspath(os.getcwd())
@@ -133,6 +127,9 @@ class Svn(Fetch):
if revision:
svncmd = "svn co -r %s %s://%s/%s" % (revision, proto, svnroot, module)
+ elif date == "now":
+ svncmd = "svn co %s://%s/%s" % (proto, svnroot, module)
+
if svn_rsh:
svncmd = "svn_RSH=\"%s\" %s" % (svn_rsh, svncmd)