summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-14 11:00:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-17 17:16:58 +0000
commitdcc891059c5f3a17781febfff4a4280b4b7c8754 (patch)
tree84bc1d2bc9f6b48e19be85903a6c89bc7e077d82
parentd69fccf2e5d108dd7c6059310924588d36a45865 (diff)
downloadopenembedded-core-dcc891059c5f3a17781febfff4a4280b4b7c8754.tar.gz
systemtap: Disable dangling-pointer warning
This is to fix build in RISCV64 | In constructor 'symresolution_info::symresolution_info(systemtap_session&, bool)', | inlined from 'int semantic_pass_symbols(systemtap_session&)' at ../git/elaborate.cxx:1884:28: | ../git/elaborate.cxx:2601:21: error: storing the address of local variable 'sym' in '*s.systemtap_session::symbol_resolver' [-Werror=dangling-pointer=] | 2601 | s.symbol_resolver = this; // save resolver for early PR25841 function resolution | | ~~~~~~~~~~~~~~~~~~^~~~~~ | ../git/elaborate.cxx: In function 'int semantic_pass_symbols(systemtap_session&)': | ../git/elaborate.cxx:1884:22: note: 'sym' declared here | 1884 | symresolution_info sym (s); | | ^~~ | ../git/elaborate.cxx:1884:22: note: 's' declared here Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 072fcb310a..d320a8a5e0 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -34,6 +34,9 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
inherit autotools gettext pkgconfig systemd
inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3-probes', 'setuptools3-base', '', d)}
+# | ../git/elaborate.cxx:2601:21: error: storing the address of local variable 'sym' in '*s.systemtap_session::symbol_resolver' [-Werror=dangling-pointer=]
+CXXFLAGS += "-Wno-dangling-pointer"
+
# exporter comes with python3-probes
PACKAGES =+ "${PN}-exporter"
FILES:${PN}-exporter = "${sysconfdir}/stap-exporter/* \