summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2023-02-21 12:15:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-24 13:31:41 +0000
commitda4d6547f312285b5e246d8f974d2de76294fef3 (patch)
tree952d359daae4b56d4a6dca7740856fd5e3cadd9e
parentde8e7e0c2cbd558678ee59fae8b0024c6d0a7b9a (diff)
downloadopenembedded-core-da4d6547f312285b5e246d8f974d2de76294fef3.tar.gz
weston: Add kiosk shell
Adds support for the kiosk shell to weston. The Kiosk shell is designed to run a fullscreen application in a "kiosk" mode, but unlike the fullscreen shell the kiosk mode still provides traditional desktop protocols. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/wayland/weston_11.0.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston_11.0.1.bb b/meta/recipes-graphics/wayland/weston_11.0.1.bb
index b943842bc4..2daecc9856 100644
--- a/meta/recipes-graphics/wayland/weston_11.0.1.bb
+++ b/meta/recipes-graphics/wayland/weston_11.0.1.bb
@@ -42,7 +42,9 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms wayla
screenshare \
shell-desktop \
shell-fullscreen \
- shell-ivi"
+ shell-ivi \
+ shell-kiosk \
+ "
# Can be 'damage', 'im', 'egl', 'shm', 'touch', 'dmabuf-feedback', 'dmabuf-v4l', 'dmabuf-egl' or 'all'
SIMPLECLIENTS ?= "all"
@@ -86,6 +88,8 @@ PACKAGECONFIG[shell-desktop] = "-Dshell-desktop=true,-Dshell-desktop=false"
PACKAGECONFIG[shell-fullscreen] = "-Dshell-fullscreen=true,-Dshell-fullscreen=false"
# In-Vehicle Infotainment (IVI) shell
PACKAGECONFIG[shell-ivi] = "-Dshell-ivi=true,-Dshell-ivi=false"
+# Kiosk shell
+PACKAGECONFIG[shell-kiosk] = "-Dshell-kiosk=true,-Dshell-kiosk=false"
# JPEG image loading support
PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg"
# support libseat based launch