summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-15 19:13:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-16 08:12:28 +0000
commitc0d0428deabf519e86bc0ffb7ff47e9bb0a165c4 (patch)
treeac671a93cfa38d119e09d3b9ca790ec5aba15846
parent158785d12a18e221be4a1fa35851c35214eee591 (diff)
downloadopenembedded-core-c0d0428deabf519e86bc0ffb7ff47e9bb0a165c4.tar.gz
python3-testtools: upgrade 2.5.0 -> 2.6.0
Improvements ------------ * Add support for Python 3.10 and 3.11. * Drop support for Python 3.5 (EOL). * Distutils integration is deprecated and will be removed in the next major version. * Use "CompoundFixture" from "fixtures>=2.0" rather than rolling our own. * Provide a "testtools[twisted]" extra documenting dependencies needed for "testtools.twistedsupport". * Make "TestCase" hashable. * Prevent "AttributeError" in "TestCase.__eq__" for objects lacking a "__dict__" attribute. * Replace deprecated "cgi" module usage with "email". Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-testtools.inc2
-rw-r--r--meta/recipes-devtools/python/python3-testtools_2.6.0.bb (renamed from meta/recipes-devtools/python/python3-testtools_2.5.0.bb)1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
index ef5e15cc3a..e004d0eb0b 100644
--- a/meta/recipes-devtools/python/python-testtools.inc
+++ b/meta/recipes-devtools/python/python-testtools.inc
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
inherit pypi
-SRC_URI[sha256sum] = "57c13433d94f9ffde3be6534177d10fb0c1507cc499319128958ca91a65cb23f"
+SRC_URI[sha256sum] = "28b65e14c0f2d3ecbbfb5f55c9dcde5e4faa80ac16a37a823909a1fe3cbcb30a"
DEPENDS += " \
${PYTHON_PN}-pbr \
diff --git a/meta/recipes-devtools/python/python3-testtools_2.5.0.bb b/meta/recipes-devtools/python/python3-testtools_2.6.0.bb
index 896ecee65c..79e46a02de 100644
--- a/meta/recipes-devtools/python/python3-testtools_2.5.0.bb
+++ b/meta/recipes-devtools/python/python3-testtools_2.6.0.bb
@@ -1,2 +1,3 @@
inherit setuptools3
require python-testtools.inc
+