summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-08-21 11:44:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-22 15:13:51 +0100
commitbb5865b10316754213711551fa68a53a4fb741d9 (patch)
tree4036daf3c60c61564e2910298dbef2581cc0912b
parent92642acd1166b7990fb520337b78a4d37ce7cbe4 (diff)
downloadopenembedded-core-bb5865b10316754213711551fa68a53a4fb741d9.tar.gz
linux-yocto/6.4: fix uninitialized read in nohz_full/isolcpus setup
Integrating the following commit(s) to linux-yocto/6.4: 4675ec8d0b9a kernel/sched: Fix uninitialized read in nohz_full/isolcpus setup The carry forward of commit from the v5.15 linux-yocto kernel: https://git.yoctoproject.org/linux-yocto/commit/?id=97c96388922 ...in which case the sanity checks are properly *after* the allocation and processing of the bootargs into the cpumask. However, it seems patch (or wiggle?) apparently decided to put the sanity checks *before* the population of the cpumask during the carry-forward and generation of the new v6.1 kernel. Meaning they are validating uninitialized memory and hence nohz_full= and isolcpus= are subject to random failures even for valid input ranges. (From OE-Core rev: b3a71c7d36e3a4833e90728499e08543257042a1) Signed-off-by: Adrian Cinal <adriancinal1@gmail.com> Acked-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.4.bb24
3 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
index 892794a142..999d54a46a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
@@ -14,8 +14,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "c5e2054d6dd1e4d87bc05758b03c8414b6229bdc"
-SRCREV_meta ?= "b7b65d4e9a3f7910d9590c325798a6d012087555"
+SRCREV_machine ?= "a6b1e0d6cfc7843898d7624427f50e5391edac51"
+SRCREV_meta ?= "be4b1defa25b1560b7d92e1ade1b7c52a226fc38"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
index 546aeea7bd..063c39bb9d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
@@ -17,8 +17,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_meta ?= "b7b65d4e9a3f7910d9590c325798a6d012087555"
+SRCREV_machine ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_meta ?= "be4b1defa25b1560b7d92e1ade1b7c52a226fc38"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.4.bb b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
index 3be24d60e6..d255504bd2 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
@@ -18,18 +18,18 @@ KBRANCH:qemux86-64 ?= "v6.4/standard/base"
KBRANCH:qemuloongarch64 ?= "v6.4/standard/base"
KBRANCH:qemumips64 ?= "v6.4/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "98ab6b8c56f20616739f11d78f9ce5e0f142e897"
-SRCREV_machine:qemuarm64 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemuloongarch64 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemumips ?= "ea17dea03919f5923b5948473fda920b9a6c2823"
-SRCREV_machine:qemuppc ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemuriscv64 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemuriscv32 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemux86 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemux86-64 ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_machine:qemumips64 ?= "d8138296adb9b11a94fcc42d345e49bbb1dd5ede"
-SRCREV_machine ?= "d58a0ccc079a8173c41eca28d801f07eb806d3e5"
-SRCREV_meta ?= "b7b65d4e9a3f7910d9590c325798a6d012087555"
+SRCREV_machine:qemuarm ?= "53136802928146b86b68bdf796f825d142e3a014"
+SRCREV_machine:qemuarm64 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemuloongarch64 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemumips ?= "bec202d0a29e4acf9d4e673f1c358e60879c95dc"
+SRCREV_machine:qemuppc ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemuriscv64 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemuriscv32 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemux86 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemux86-64 ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_machine:qemumips64 ?= "e9dcec67cb7b9703d6eac9a705e94e5f5aab4f0c"
+SRCREV_machine ?= "a0b10018f36e04152354dc83c41134406e137571"
+SRCREV_meta ?= "be4b1defa25b1560b7d92e1ade1b7c52a226fc38"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same