summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha Jalabert <samantha.jalabert@syslinbit.com>2023-09-22 14:46:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-27 11:47:36 +0100
commitb8ee52ee86042a4e9b4cce46ac603fbd930cd5b4 (patch)
treedd43fcfedad3c415fde5a18be7f8b9ef97f105e9
parent4247474286d55db285a56af7aaa700c2cc75adf3 (diff)
downloadopenembedded-core-b8ee52ee86042a4e9b4cce46ac603fbd930cd5b4.tar.gz
python3-rdflib: Copy recipe from meta-python
commit: 7e565b5c0c09a9cd7c27eb24f8fb45a746469279 Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-rdflib_7.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
new file mode 100644
index 0000000000..952c210116
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "RDFLib is a pure Python package for working with RDF"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37d489c0cefe52a17e1d5007e196464a"
+
+SRC_URI[sha256sum] = "9995eb8569428059b8c1affd26b25eac510d64f5043d9ce8c84e0d0036e995ae"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-isodate \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"