summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2024-12-12 08:48:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-12-13 11:19:55 +0000
commitb8c26b320abce65862632f0e832d93ba37c6dc41 (patch)
tree9dd35681df248998191584b3ad94b29b84eec130
parent57731284008c18eee566df3412eaf6d13a59d498 (diff)
downloadopenembedded-core-b8c26b320abce65862632f0e832d93ba37c6dc41.tar.gz
barebox: upgrade 2024.10.0 -> 2024.12.0
0001-lib-lz4-use-lz4-instead-of-lz4c.patch removed since it's included in 2024.12.0 Changelog: =========== * ARM: omap: fix NS16550 UART setup in omap_debug_ll_init * Documentation: imd: update information on barebox_update * partitions: efi: Check GPT header size against minimum limit * checkpatch: fix detection of barebox root directory * ARM: omap: add two smaller MLO defconfigs for AM335x * crc: crc-itu-t: generate lookup table on first use * of: fdt: fix possible overflow during parsing of fdt * remoteproc: use I/O memory variants of memcpy/memset * dlmalloc: Fix integer overflow in request2size() * remoteproc: imx: add support for loading ELF data sections into DRAM * remoteproc: elf_loader: skip segment with memsz as zero * of: fdt: fix overflow caused by fdt_prop extending beyond fdt * usb: typec: fix freeing uninitialized memory Ahmad Fatoum * startup: do not bring up networking if console input disabled * sandbox: noshell_defconfig: set CONFIG_CONSOLE_DISABLE_INPUT=y * ARM: dts: i.MX8MP: disable NPU node if hardware is missing * clk: clk-composite: fix callback guard in clk_composite_round_rate * partitions: efi: fix overflow issues while allocating gpt entries * lib: lz4: use lz4 instead of lz4c * clk: rockchip: make it compile again * ARM: i.MX: ele: fix forward_lifecycle * ARM: i.MX9: tqma93xx: workaround warning in variant detection * partitions: efi: fix GPT header size exceeding allocation size * video: Rockchip: add missing dma_alloc_coherent a device parameter * dma: give dma_alloc_coherent a device parameter * common: buffer access out-of-bounds * include: Include <linux/math.h> to resolve implicit declaration of do_div() * i2c: lpi2c: fix potential read of uninitialized variable Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Mathieu Dubois-Briand <mathieu.dubois-briand@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/barebox/barebox-common.inc4
-rw-r--r--meta/recipes-bsp/barebox/barebox.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-bsp/barebox/barebox-common.inc b/meta/recipes-bsp/barebox/barebox-common.inc
index 5dcdb70757..fce3b825ae 100644
--- a/meta/recipes-bsp/barebox/barebox-common.inc
+++ b/meta/recipes-bsp/barebox/barebox-common.inc
@@ -3,6 +3,6 @@ SECTION = "bootloaders"
LIC_FILES_CHKSUM = "file://COPYING;md5=f5125d13e000b9ca1f0d3364286c4192"
-PV = "2024.10.0"
+PV = "2024.12.0"
SRC_URI = "https://barebox.org/download/barebox-${PV}.tar.bz2"
-SRC_URI[sha256sum] = "955b20bfa7358732d2c0c09ccfd4c1a69087b7e2c610b16dee7442d71a5af88d"
+SRC_URI[sha256sum] = "717a2416b37942f584b0bb2eb61ccbf85dc0f1a5c841318f47cd6967b9c4dcab"
diff --git a/meta/recipes-bsp/barebox/barebox.bb b/meta/recipes-bsp/barebox/barebox.bb
index dc9ae669d7..a48d97941c 100644
--- a/meta/recipes-bsp/barebox/barebox.bb
+++ b/meta/recipes-bsp/barebox/barebox.bb
@@ -8,5 +8,3 @@ and a subset of the POSIX C library for writing more command-line utilities."
require barebox-common.inc
inherit barebox
-SRC_URI += "file://0001-lib-lz4-use-lz4-instead-of-lz4c.patch \
- "