summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-27 14:46:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-29 21:21:27 +0000
commitb8bbc1bbe282cce2ea4d0ff293f931f6caf6153b (patch)
treea653a4508cfcb7a1797819ec7d9037b282fa199b
parent06bf68012302330c2b14f59541f78f48c7389c37 (diff)
downloadopenembedded-core-b8bbc1bbe282cce2ea4d0ff293f931f6caf6153b.tar.gz
bitbake.conf/python: Drop setting RDEPENDS/RPROVIDES default
We never recommend setting RDEPENDS or RPROVIDES without a package name against them. The default in bitbake.conf is legacy only, drop it. The python recipe was trying to add to the empty variable in the native case fix that too. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/bitbake.conf2
-rw-r--r--meta/recipes-devtools/python/python3_3.9.1.bb2
2 files changed, 1 insertions, 3 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 74976ac05c..3438be92b7 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -272,10 +272,8 @@ DEPCHAIN_PRE = ""
DEPCHAIN_POST = "-dev -dbg"
DEPENDS = ""
-RDEPENDS = ""
PROVIDES = ""
PROVIDES_prepend = "${PN} "
-RPROVIDES = ""
MULTI_PROVIDER_WHITELIST = "virtual/libintl virtual/libintl-native virtual/nativesdk-libintl virtual/xserver virtual/update-alternatives-native virtual/update-alternatives"
diff --git a/meta/recipes-devtools/python/python3_3.9.1.bb b/meta/recipes-devtools/python/python3_3.9.1.bb
index a89122f949..a2dc572672 100644
--- a/meta/recipes-devtools/python/python3_3.9.1.bb
+++ b/meta/recipes-devtools/python/python3_3.9.1.bb
@@ -240,7 +240,7 @@ python(){
# First set RPROVIDES for -native case
# Hardcoded since it cant be python3-native-foo, should be python3-foo-native
pn = 'python3'
- rprovides = d.getVar('RPROVIDES').split()
+ rprovides = (d.getVar('RPROVIDES') or "").split()
# ${PN}-misc-native is not in the manifest
rprovides.append(pn + '-misc-native')