summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-08 09:40:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-08 16:41:52 +0000
commitb58d86f9902a7eb7a821a3e36ba298c082c0f1f1 (patch)
treecf1602eec3b305ea642dc6087dc8d645f689d130
parent73fd4fb86183fe4d651acfc8f2a65b9d7335ba8e (diff)
downloadopenembedded-core-b58d86f9902a7eb7a821a3e36ba298c082c0f1f1.tar.gz
lua: Fix install conflict when enable multilib.
Error: Transaction test error: file /usr/include/luaconf.h conflicts between attempted installs of lua-dev-5.4.4-r0.aarch64 and lib32-lua-dev-5.4.4-r0.armv7ahf_neon The differences between the two files are as follows: @@ -219,7 +219,7 @@ #define LUA_ROOT "/usr/" #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/" -#define LUA_CDIR LUA_ROOT "lib64/lua/" LUA_VDIR "/" +#define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/" #if !defined(LUA_PATH_DEFAULT) #define LUA_PATH_DEFAULT \ Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/lua/lua_5.4.4.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/lua/lua_5.4.4.bb b/meta/recipes-devtools/lua/lua_5.4.4.bb
index 0b2e754b31..a39d888ec2 100644
--- a/meta/recipes-devtools/lua/lua_5.4.4.bb
+++ b/meta/recipes-devtools/lua/lua_5.4.4.bb
@@ -57,3 +57,6 @@ do_install_ptest () {
}
BBCLASSEXTEND = "native nativesdk"
+
+inherit multilib_script
+MULTILIB_SCRIPTS = "${PN}-dev:${includedir}/luaconf.h"