summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2021-09-16 13:02:46 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-17 07:27:17 +0100
commit9b5b797b0e9e6f2cb3e29be92c4f9b763c4a41e9 (patch)
treef184875befd7fb3fc53f4fb31415546390681467
parentb1821691c2d7eafb29cf182fc1f2ec7b0cc8340f (diff)
downloadopenembedded-core-9b5b797b0e9e6f2cb3e29be92c4f9b763c4a41e9.tar.gz
expat: pull from github releases
sometimes we can find release tarballs from sourceforge are not fully distributed along all download mirrors leading to fetching faiilures, depending on what download mirror will be chosen by sourceforge servers. As the project moved to github anyway, it's better to pull the tarballs directly from github releases - serving the very same static artifacts. Add an override UPSTREAM_CHECK_URI to enable devtool upgrade checks Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/expat/expat_2.4.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/expat/expat_2.4.1.bb b/meta/recipes-core/expat/expat_2.4.1.bb
index 555dd0d601..14e5aca9e6 100644
--- a/meta/recipes-core/expat/expat_2.4.1.bb
+++ b/meta/recipes-core/expat/expat_2.4.1.bb
@@ -6,11 +6,15 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
+VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
+
+SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
file://libtool-tag.patch \
file://run-ptest \
"
+UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
+
SRC_URI[sha256sum] = "2f9b6a580b94577b150a7d5617ad4643a4301a6616ff459307df3e225bcfbf40"
EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"