summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2024-05-26 12:43:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-30 09:04:11 +0100
commit99e0a6ed8a08faa86116fbb8989bbb234bd7fc53 (patch)
treec40d459768aca099f69fd0c17cac54478e496a8c
parent5efe057e6cf0b5f217d9a5af0cec93b92435ad62 (diff)
downloadopenembedded-core-99e0a6ed8a08faa86116fbb8989bbb234bd7fc53.tar.gz
kmod: upgrade from 31 to 32
kmod now installs symlinks in 'make install'. https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git/commit/? id=e98cef6f3f8cd6f8bfb26d147b2c209297453cca Changes are made in do_install to ensure that we can to continue to use sbin. This is because our kernel has: CONFIG_MODPROBE_PATH='/sbin/modprobe'. We'll need to sync our kmod path settings with our kernel config. Otherwise, things would fail. For example, libnl's some ptest cases fail. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/kmod/kmod_32.bb (renamed from meta/recipes-kernel/kmod/kmod_31.bb)5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_31.bb b/meta/recipes-kernel/kmod/kmod_32.bb
index 718a5565b4..1c4e5a94db 100644
--- a/meta/recipes-kernel/kmod/kmod_31.bb
+++ b/meta/recipes-kernel/kmod/kmod_32.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
"
inherit autotools bash-completion gtk-doc pkgconfig manpages update-alternatives
-SRCREV = "aff617ea871d0568cc491bd116c0be1e857463bb"
+SRCREV = "41faa59711742c1476d59985011ee0f27ed91d30"
SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git;branch=master;protocol=https \
file://depmod-search.conf \
@@ -52,8 +52,9 @@ do_install:append () {
install -dm755 ${D}${base_bindir}
install -dm755 ${D}${base_sbindir}
# add symlinks to kmod
- ln -rs ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
+ [ -e ${D}${base_bindir}/lsmod ] || ln -rs ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
for tool in insmod rmmod depmod modinfo modprobe; do
+ rm -f ${D}${base_bindir}/${tool}
ln -rs ${D}${base_bindir}/kmod ${D}${base_sbindir}/${tool}
done
# configuration directories