summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-01-21 10:40:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-24 22:06:48 +0000
commit904574c49c51f1862c6b888a3e5889bd972df42d (patch)
treebae740ebb0e702636c589ef216c8394b5d231838
parent2b24ffade16fc23ddb77e26d8967c26d62f4ed6d (diff)
downloadopenembedded-core-904574c49c51f1862c6b888a3e5889bd972df42d.tar.gz
python3-cryptography{-vectors}: 38.0.4 -> 39.0.0
* python3-cryptography-crates.inc: update for 39.0.0 * python3-cryptography-vectors: upgrade 38.0.4 -> 39.0.0 Highlights from Changelog: https://cryptography.io/en/latest/changelog/#v39-0-0 39.0.0 - 2023-01-01 * BACKWARDS INCOMPATIBLE: Support for OpenSSL 1.1.0 has been removed. Users on older version of OpenSSL will need to upgrade. * BACKWARDS INCOMPATIBLE: Dropped support for LibreSSL < 3.5. The new minimum LibreSSL version is 3.5.0. Going forward our policy is to support versions of LibreSSL that are available in versions of OpenBSD that are still receiving security support. * BACKWARDS INCOMPATIBLE: Removed the encode_point and from_encoded_point methods on EllipticCurvePublicNumbers, which had been deprecated for several years. public_bytes() and from_encoded_point() should be used instead. * BACKWARDS INCOMPATIBLE: Support for using MD5 or SHA1 in CertificateBuilder, other X.509 builders, and PKCS7 has been removed. * ANNOUNCEMENT: The next version of cryptography (40.0) will change the way we link OpenSSL. This will only impact users who build cryptography from source (i.e., not from a wheel), and specify their own version of OpenSSL. For those users, the CFLAGS, LDFLAGS, INCLUDE, LIB, and CRYPTOGRAPHY_SUPPRESS_LINK_FLAGS environment variables will no longer be respected. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-crates.inc123
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_39.0.0.bb (renamed from meta/recipes-devtools/python/python3-cryptography-vectors_38.0.4.bb)2
-rw-r--r--meta/recipes-devtools/python/python3-cryptography_39.0.0.bb (renamed from meta/recipes-devtools/python/python3-cryptography_38.0.4.bb)2
3 files changed, 70 insertions, 57 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-crates.inc b/meta/recipes-devtools/python/python3-cryptography-crates.inc
index 9339a15091..a0c8fa50c9 100644
--- a/meta/recipes-devtools/python/python3-cryptography-crates.inc
+++ b/meta/recipes-devtools/python/python3-cryptography-crates.inc
@@ -1,58 +1,71 @@
# Autogenerated with 'bitbake -c update_crates python3-cryptography'
-SRC_URI += " \
- crate://crates.io/Inflector/0.11.4 \
- crate://crates.io/aliasable/0.1.3 \
- crate://crates.io/android_system_properties/0.1.5 \
- crate://crates.io/asn1/0.12.2 \
- crate://crates.io/asn1_derive/0.12.2 \
- crate://crates.io/autocfg/1.1.0 \
- crate://crates.io/base64/0.13.0 \
- crate://crates.io/bitflags/1.3.2 \
- crate://crates.io/bumpalo/3.10.0 \
- crate://crates.io/cfg-if/1.0.0 \
- crate://crates.io/chrono/0.4.22 \
- crate://crates.io/core-foundation-sys/0.8.3 \
- crate://crates.io/iana-time-zone/0.1.47 \
- crate://crates.io/indoc/0.3.6 \
- crate://crates.io/indoc-impl/0.3.6 \
- crate://crates.io/instant/0.1.12 \
- crate://crates.io/js-sys/0.3.59 \
- crate://crates.io/libc/0.2.132 \
- crate://crates.io/lock_api/0.4.8 \
- crate://crates.io/log/0.4.17 \
- crate://crates.io/num-integer/0.1.45 \
- crate://crates.io/num-traits/0.2.15 \
- crate://crates.io/once_cell/1.14.0 \
- crate://crates.io/ouroboros/0.15.4 \
- crate://crates.io/ouroboros_macro/0.15.4 \
- crate://crates.io/parking_lot/0.11.2 \
- crate://crates.io/parking_lot_core/0.8.5 \
- crate://crates.io/paste/0.1.18 \
- crate://crates.io/paste-impl/0.1.18 \
- crate://crates.io/pem/1.1.0 \
- crate://crates.io/proc-macro-error/1.0.4 \
- crate://crates.io/proc-macro-error-attr/1.0.4 \
- crate://crates.io/proc-macro-hack/0.5.19 \
- crate://crates.io/proc-macro2/1.0.43 \
- crate://crates.io/pyo3/0.15.2 \
- crate://crates.io/pyo3-build-config/0.15.2 \
- crate://crates.io/pyo3-macros/0.15.2 \
- crate://crates.io/pyo3-macros-backend/0.15.2 \
- crate://crates.io/quote/1.0.21 \
- crate://crates.io/redox_syscall/0.2.16 \
- crate://crates.io/scopeguard/1.1.0 \
- crate://crates.io/smallvec/1.9.0 \
- crate://crates.io/syn/1.0.99 \
- crate://crates.io/unicode-ident/1.0.3 \
- crate://crates.io/unindent/0.1.10 \
- crate://crates.io/version_check/0.9.4 \
- crate://crates.io/wasm-bindgen/0.2.82 \
- crate://crates.io/wasm-bindgen-backend/0.2.82 \
- crate://crates.io/wasm-bindgen-macro/0.2.82 \
- crate://crates.io/wasm-bindgen-macro-support/0.2.82 \
- crate://crates.io/wasm-bindgen-shared/0.2.82 \
- crate://crates.io/winapi/0.3.9 \
- crate://crates.io/winapi-i686-pc-windows-gnu/0.4.0 \
- crate://crates.io/winapi-x86_64-pc-windows-gnu/0.4.0 \
+# from src/rust/Cargo.lock
+SRC_URI += " \
+ crate://crates.io/Inflector/0.11.4 \
+ crate://crates.io/aliasable/0.1.3 \
+ crate://crates.io/android_system_properties/0.1.5 \
+ crate://crates.io/asn1/0.13.0 \
+ crate://crates.io/asn1_derive/0.13.0 \
+ crate://crates.io/autocfg/1.1.0 \
+ crate://crates.io/base64/0.13.1 \
+ crate://crates.io/bitflags/1.3.2 \
+ crate://crates.io/bumpalo/3.10.0 \
+ crate://crates.io/cc/1.0.78 \
+ crate://crates.io/cfg-if/1.0.0 \
+ crate://crates.io/chrono/0.4.23 \
+ crate://crates.io/codespan-reporting/0.11.1 \
+ crate://crates.io/core-foundation-sys/0.8.3 \
+ crate://crates.io/cxx/1.0.85 \
+ crate://crates.io/cxx-build/1.0.85 \
+ crate://crates.io/cxxbridge-flags/1.0.85 \
+ crate://crates.io/cxxbridge-macro/1.0.85 \
+ crate://crates.io/iana-time-zone/0.1.53 \
+ crate://crates.io/iana-time-zone-haiku/0.1.1 \
+ crate://crates.io/indoc/0.3.6 \
+ crate://crates.io/indoc-impl/0.3.6 \
+ crate://crates.io/instant/0.1.12 \
+ crate://crates.io/js-sys/0.3.60 \
+ crate://crates.io/libc/0.2.139 \
+ crate://crates.io/link-cplusplus/1.0.8 \
+ crate://crates.io/lock_api/0.4.9 \
+ crate://crates.io/log/0.4.17 \
+ crate://crates.io/num-integer/0.1.45 \
+ crate://crates.io/num-traits/0.2.15 \
+ crate://crates.io/once_cell/1.14.0 \
+ crate://crates.io/ouroboros/0.15.5 \
+ crate://crates.io/ouroboros_macro/0.15.5 \
+ crate://crates.io/parking_lot/0.11.2 \
+ crate://crates.io/parking_lot_core/0.8.6 \
+ crate://crates.io/paste/0.1.18 \
+ crate://crates.io/paste-impl/0.1.18 \
+ crate://crates.io/pem/1.1.0 \
+ crate://crates.io/proc-macro-error/1.0.4 \
+ crate://crates.io/proc-macro-error-attr/1.0.4 \
+ crate://crates.io/proc-macro-hack/0.5.20+deprecated \
+ crate://crates.io/proc-macro2/1.0.49 \
+ crate://crates.io/pyo3/0.15.2 \
+ crate://crates.io/pyo3-build-config/0.15.2 \
+ crate://crates.io/pyo3-macros/0.15.2 \
+ crate://crates.io/pyo3-macros-backend/0.15.2 \
+ crate://crates.io/quote/1.0.23 \
+ crate://crates.io/redox_syscall/0.2.16 \
+ crate://crates.io/scopeguard/1.1.0 \
+ crate://crates.io/scratch/1.0.3 \
+ crate://crates.io/smallvec/1.10.0 \
+ crate://crates.io/syn/1.0.107 \
+ crate://crates.io/termcolor/1.1.3 \
+ crate://crates.io/unicode-ident/1.0.6 \
+ crate://crates.io/unicode-width/0.1.10 \
+ crate://crates.io/unindent/0.1.11 \
+ crate://crates.io/version_check/0.9.4 \
+ crate://crates.io/wasm-bindgen/0.2.83 \
+ crate://crates.io/wasm-bindgen-backend/0.2.83 \
+ crate://crates.io/wasm-bindgen-macro/0.2.83 \
+ crate://crates.io/wasm-bindgen-macro-support/0.2.83 \
+ crate://crates.io/wasm-bindgen-shared/0.2.83 \
+ crate://crates.io/winapi/0.3.9 \
+ crate://crates.io/winapi-i686-pc-windows-gnu/0.4.0 \
+ crate://crates.io/winapi-util/0.1.5 \
+ crate://crates.io/winapi-x86_64-pc-windows-gnu/0.4.0 \
"
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_38.0.4.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_39.0.0.bb
index a36cbeb09a..6aaf6501b4 100644
--- a/meta/recipes-devtools/python/python3-cryptography-vectors_38.0.4.bb
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_39.0.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
# Upgrade both recipes at the same time
-SRC_URI[sha256sum] = "6ec62695bec5df810288ddceae998ae691cdb8a162808d6cbc960d3deb9a7db1"
+SRC_URI[sha256sum] = "52e59670a0820b5bbfa85f724b8aebd61385787eb8b6607f64d533969124b2a0"
PYPI_PACKAGE = "cryptography_vectors"
diff --git a/meta/recipes-devtools/python/python3-cryptography_38.0.4.bb b/meta/recipes-devtools/python/python3-cryptography_39.0.0.bb
index 5d279e7db1..cca192bc84 100644
--- a/meta/recipes-devtools/python/python3-cryptography_38.0.4.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_39.0.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba \
"
LDSHARED += "-pthread"
-SRC_URI[sha256sum] = "175c1a818b87c9ac80bb7377f5520b7f31b3ef2a0004e2420319beadedb67290"
+SRC_URI[sha256sum] = "f964c7dcf7802d133e8dbd1565914fa0194f9d683d82411989889ecd701e8adf"
SRC_URI += "\
file://0002-Cargo.toml-edition-2018-2021.patch \