summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-03-01 10:13:39 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-02 22:06:08 +0000
commit7d7044e8031009ecebd8586ce52d1c1207546668 (patch)
tree34266a8456e72000e73d951b34bd2f0333a95a26
parentabbcf19d7e46682d3ac7b4fda6e67543b9e9866f (diff)
downloadopenembedded-core-7d7044e8031009ecebd8586ce52d1c1207546668.tar.gz
linux-yocto-rt/6.1: fix compilation issue with per cpu stats
Integrating the following commit(s) to linux-yocto/6.1: 3b4c5ff8e4f1 net: fix net/netfilter/ipvs/ip_vs_ctl.c with u64 and u64_stats_t Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.1.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
index 28b7159359..7a7537505e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "94f73e8d6872df48a7c4ee6caa1701ae2a535dfe"
-SRCREV_meta ?= "d7393c5752865634e307673043da55e353139333"
+SRCREV_machine ?= "8183fc0efdb87bd314afda93a7c02ff85dc5833d"
+SRCREV_meta ?= "a833bd2ced5dcd01c043348ec47218a545d00c5f"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
index 65866dd1db..393952a980 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
@@ -15,7 +15,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "1caf99d56881e1510afca553cd4a057f80479973"
-SRCREV_meta ?= "d7393c5752865634e307673043da55e353139333"
+SRCREV_meta ?= "a833bd2ced5dcd01c043348ec47218a545d00c5f"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
index 66d397837f..8c99b98933 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
@@ -25,7 +25,7 @@ SRCREV_machine:qemux86 ?= "1caf99d56881e1510afca553cd4a057f80479973"
SRCREV_machine:qemux86-64 ?= "1caf99d56881e1510afca553cd4a057f80479973"
SRCREV_machine:qemumips64 ?= "2949d76c3f79f3c7f700a6366d828f006d7dd5a8"
SRCREV_machine ?= "1caf99d56881e1510afca553cd4a057f80479973"
-SRCREV_meta ?= "d7393c5752865634e307673043da55e353139333"
+SRCREV_meta ?= "a833bd2ced5dcd01c043348ec47218a545d00c5f"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same