summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Mason <jdmason@kudzu.us>2021-09-16 18:19:32 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-17 07:30:32 +0100
commit6450138afebffcc55ab32afadd5fb979274fff2b (patch)
treeb5f0068c2e4d7261467dea7f5f1cb70601ed37e8
parent83169c33f7585da25560784f79eaad2c6f029f3c (diff)
downloadopenembedded-core-6450138afebffcc55ab32afadd5fb979274fff2b.tar.gz
core-image-sato: Fix runqemu error for qemuarmv5
When attempting to execute runqemu on qemuarmv5, the following error is encountered: runqemu - ERROR - Failed to run qemu: qemu-system-arm: versatilepb: memory size must not exceed 256MB To work around this, limit the QB_MEM size for qemuarmv5, similar to what is being done for qemumips. Signed-off-by: Jon Mason <jdmason@kudzu.us> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index 35d0667737..e63a229d12 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -13,4 +13,5 @@ TOOLCHAIN_HOST_TASK:append = " nativesdk-intltool nativesdk-glib-2.0"
TOOLCHAIN_HOST_TASK:remove:task-populate-sdk-ext = " nativesdk-intltool nativesdk-glib-2.0"
QB_MEM = '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
+QB_MEM:qemuarmv5 = "-m 256"
QB_MEM:qemumips = "-m 256"