summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-09-06 13:45:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-09-09 14:33:50 +0100
commit40aaef7d87c0b845019a269deebf7b101ffddf7e (patch)
treed0f195d16837e84e1b520fbf76bbcf771331eac4
parent475c48dae4fcc316ecbb12d32a7a57377af1da85 (diff)
downloadopenembedded-core-40aaef7d87c0b845019a269deebf7b101ffddf7e.tar.gz
linux-yocto/6.10: fix CONFIG_PWM_SYSFS config warning
Integrating the following commit(s) to linux-yocto/.: 1/1 [ Author: Yogesh Tyagi Email: yogesh.tyagi@intel.com Subject: bsp : remove sysfs configs for pwm class Date: Fri, 23 Aug 2024 12:54:56 +0530 Following commit removed the CONFIG_PWM_SYSFS from linux kernel: https://github.com/torvalds/linux/commit/e9cc807f87ffd1ccc919731e8f624982935af3e0 Having these configs is causing below warning during linux-yocto-6.10 kernel build: WARNING: linux-yocto-6.10.3+git-r0 do_kernel_configcheck: [kernel config]: This BSP contains fragments with warnings: [INFO]: the following symbols were not found in the active configuration: - CONFIG_PWM_SYSFS This changes is needed in 6.10 as well as master branch Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> ] Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.10.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.10.bb
index 0c0620469e..c217ab779b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.10.bb
@@ -15,7 +15,7 @@ python () {
}
SRCREV_machine ?= "c0094e55e84db839eb3624a2f99d826dd3cbb3e3"
-SRCREV_meta ?= "5161bedbdc3ff6f22a75fb5afb96a4077f4b4ab0"
+SRCREV_meta ?= "e4d2ade39f231ea279f19298c008ba48f4a202e5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.10;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.10.bb
index deb19c3dc8..f7993bbf15 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.10.bb
@@ -18,7 +18,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "92466d9d49ed65d9a13f2ab648a92becc027a257"
-SRCREV_meta ?= "5161bedbdc3ff6f22a75fb5afb96a4077f4b4ab0"
+SRCREV_meta ?= "e4d2ade39f231ea279f19298c008ba48f4a202e5"
PV = "${LINUX_VERSION}+git"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.10.bb b/meta/recipes-kernel/linux/linux-yocto_6.10.bb
index c0b1b0b6cc..fb3c244a94 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.10.bb
@@ -29,7 +29,7 @@ SRCREV_machine:qemux86 ?= "92466d9d49ed65d9a13f2ab648a92becc027a257"
SRCREV_machine:qemux86-64 ?= "92466d9d49ed65d9a13f2ab648a92becc027a257"
SRCREV_machine:qemumips64 ?= "c1f8e21e4999d233df12ee60c7a47cad144e7344"
SRCREV_machine ?= "92466d9d49ed65d9a13f2ab648a92becc027a257"
-SRCREV_meta ?= "5161bedbdc3ff6f22a75fb5afb96a4077f4b4ab0"
+SRCREV_meta ?= "e4d2ade39f231ea279f19298c008ba48f4a202e5"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same