summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2024-07-31 12:47:53 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-08-03 07:44:28 +0100
commit3bc8f132f2547105a4e631d909347b6e80e1f6d0 (patch)
treef40d71cc907425b35dc68286f66b9a99d0a4ed94
parentf099cc0782db9c726eff151a11c1c59a1a22b3d7 (diff)
downloadopenembedded-core-3bc8f132f2547105a4e631d909347b6e80e1f6d0.tar.gz
cmake: upgrade 3.29.3 -> 3.30.1
Refresh 0001-CMakeLists.txt-disable-USE_NGHTTP2.patch to apply on top of the new version. Changelogs: 3.29.4+: https://cmake.org/cmake/help/latest/release/3.29.html#id2 3.30.x: https://cmake.org/cmake/help/latest/release/3.30.html Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.30.1.bb (renamed from meta/recipes-devtools/cmake/cmake-native_3.29.3.bb)0
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc2
-rw-r--r--meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch19
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.30.1.bb (renamed from meta/recipes-devtools/cmake/cmake_3.29.3.bb)0
4 files changed, 14 insertions, 7 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.29.3.bb b/meta/recipes-devtools/cmake/cmake-native_3.30.1.bb
index ddc41f289e..ddc41f289e 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.29.3.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.30.1.bb
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index 1155c1bbe0..604a22a2f0 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -19,7 +19,7 @@ CMAKE_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:2])}"
SRC_URI = "https://cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz \
"
-SRC_URI[sha256sum] = "252aee1448d49caa04954fd5e27d189dd51570557313e7b281636716a238bccb"
+SRC_URI[sha256sum] = "df9b3c53e3ce84c3c1b7c253e5ceff7d8d1f084ff0673d048f260e04ccb346e1"
UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
diff --git a/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch b/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
index b7ec3e7bac..090f441f0f 100644
--- a/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
+++ b/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
@@ -1,4 +1,4 @@
-From 946011cbfd686fe6bd2cec94494f6b0c4394bb6c Mon Sep 17 00:00:00 2001
+From a2cd906c36a04c8ce5a0095ae53892902b30d728 Mon Sep 17 00:00:00 2001
From: Changqing Li <changqing.li@windriver.com>
Date: Wed, 28 Dec 2022 17:51:27 +0800
Subject: [PATCH] CMakeLists.txt: disable USE_NGHTTP2
@@ -13,20 +13,27 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
Adjust the patch to apply on top of v3.28.3.
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+
+Adjust the patch to apply on top of v3.30.1.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
Utilities/cmcurl/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Utilities/cmcurl/CMakeLists.txt b/Utilities/cmcurl/CMakeLists.txt
-index 3dd24f1e..4a0f6773 100644
+index b766aee425..34ae7d2a39 100644
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -91,7 +91,7 @@ set(HTTP_ONLY OFF CACHE INTERNAL "Curl is not http-only")
- set(PICKY_COMPILER OFF CACHE INTERNAL "Enable picky compiler options")
- set(SHARE_LIB_OBJECT OFF)
+@@ -94,7 +94,7 @@ set(USE_ECH OFF)
+ set(USE_HTTPSRR OFF)
set(USE_LIBIDN2 ON)
+ set(USE_LIBRTMP OFF)
-set(USE_NGHTTP2 ON)
+set(USE_NGHTTP2 OFF)
set(USE_NGTCP2 OFF)
+ set(USE_OPENSSL_QUIC OFF)
set(USE_QUICHE OFF)
- set(USE_WIN32_IDN OFF)
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/cmake/cmake_3.29.3.bb b/meta/recipes-devtools/cmake/cmake_3.30.1.bb
index 9146fa8c0f..9146fa8c0f 100644
--- a/meta/recipes-devtools/cmake/cmake_3.29.3.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.30.1.bb