summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-05 11:42:57 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-06 15:12:34 +0100
commit368537ab94e141e02eb981fa0fb44548b4be297e (patch)
tree4b4f22da51b5cb26f0e74e0644345c7778cea80a
parent06f0e54c06a9e07dabb612a907bbf2542b5ac52e (diff)
downloadopenembedded-core-368537ab94e141e02eb981fa0fb44548b4be297e.tar.gz
kernel-devsrc: fix x86 (32bit) on target module build
The previous devsrc v5.8 on target build fixup [532ae127c kernel-devsrc: fix on-target module build for v5.8+], missed on condition: the defconfig On 32bit x86 the arch can be queried differently on the host and target. We aren't building against the defconfig, so we remove it from auto.conf.cmd and we can again prepare to build modules on target. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 0c98535f75..6a606c3570 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -263,6 +263,8 @@ do_install() {
sed -i 's/ifneq "$(LD)" ".*-linux-ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
+ # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig
+ sed -i 's/ifneq "$(KBUILD_DEFCONFIG)".*"\(.*\)"/ifneq "\1" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
fi
# make the scripts python3 safe. We won't be running these, and if they are