summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-09-03 16:32:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-09-04 12:36:43 +0100
commit14e7455069137ec8ef2866fa3160e92f86fc71d8 (patch)
treecfb95dee1c8710c6b66dcbc546d6fdeac5c67bac
parent48e00b925648dc394bf3ba08324b333b44a5ec0b (diff)
downloadopenembedded-core-14e7455069137ec8ef2866fa3160e92f86fc71d8.tar.gz
python3-pbr: upgrade 6.0.0 -> 6.1.0
0001-change-shebang-to-python3.patch refreshed for 6.1.0 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-pbr/0001-change-shebang-to-python3.patch13
-rw-r--r--meta/recipes-devtools/python/python3-pbr_6.0.0.bb4
-rw-r--r--meta/recipes-devtools/python/python3-pbr_6.1.0.bb4
3 files changed, 9 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python3-pbr/0001-change-shebang-to-python3.patch b/meta/recipes-devtools/python/python3-pbr/0001-change-shebang-to-python3.patch
index 688da6b204..218add1778 100644
--- a/meta/recipes-devtools/python/python3-pbr/0001-change-shebang-to-python3.patch
+++ b/meta/recipes-devtools/python/python3-pbr/0001-change-shebang-to-python3.patch
@@ -1,4 +1,4 @@
-From 09bd8368bf0d5385663a10eeb890131481681bdd Mon Sep 17 00:00:00 2001
+From df0a8c56f03004738599e06a7b5a1d2b67189848 Mon Sep 17 00:00:00 2001
From: Changqing Li <changqing.li@windriver.com>
Date: Thu, 23 Apr 2020 09:28:58 +0000
Subject: [PATCH] change shebang to python3
@@ -12,10 +12,10 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/pbr/tests/test_integration.py b/pbr/tests/test_integration.py
-index 8e96f21..b07cbe3 100644
+index cb4b5e5..4cbfb19 100644
--- a/pbr/tests/test_integration.py
+++ b/pbr/tests/test_integration.py
-@@ -150,7 +150,7 @@ class TestInstallWithoutPbr(base.BaseTestCase):
+@@ -171,7 +171,7 @@ class TestInstallWithoutPbr(base.BaseTestCase):
pkgs = {
'pkgTest': {
'setup.py': textwrap.dedent("""\
@@ -25,10 +25,10 @@ index 8e96f21..b07cbe3 100644
setuptools.setup(
name = 'pkgTest',
diff --git a/pbr/tests/test_packaging.py b/pbr/tests/test_packaging.py
-index 07be547..f6a9412 100644
+index dddf7ae..bec03ce 100644
--- a/pbr/tests/test_packaging.py
+++ b/pbr/tests/test_packaging.py
-@@ -206,7 +206,7 @@ class CreatePackages(fixtures.Fixture):
+@@ -219,7 +219,7 @@ class CreatePackages(fixtures.Fixture):
defaults = {
'setup.py': textwrap.dedent(six.u("""\
@@ -37,6 +37,3 @@ index 07be547..f6a9412 100644
import setuptools
setuptools.setup(
setup_requires=['pbr'],
---
-2.24.1
-
diff --git a/meta/recipes-devtools/python/python3-pbr_6.0.0.bb b/meta/recipes-devtools/python/python3-pbr_6.0.0.bb
deleted file mode 100644
index 6c8171196a..0000000000
--- a/meta/recipes-devtools/python/python3-pbr_6.0.0.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-inherit setuptools3
-require python-pbr.inc
-
-SRC_URI[sha256sum] = "d1377122a5a00e2f940ee482999518efe16d745d423a670c27773dfbc3c9a7d9"
diff --git a/meta/recipes-devtools/python/python3-pbr_6.1.0.bb b/meta/recipes-devtools/python/python3-pbr_6.1.0.bb
new file mode 100644
index 0000000000..a58b491a82
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pbr_6.1.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools3
+require python-pbr.inc
+
+SRC_URI[sha256sum] = "788183e382e3d1d7707db08978239965e8b9e4e5ed42669bf4758186734d5f24"