summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2024-05-16 13:26:39 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-28 09:38:20 +0100
commit1018619f1b18f8045ae84d65d16becf3fe21ffe0 (patch)
treef05a781ba57ff4b17df33abab3d4f5d0c45c8477
parent04ffb341864b443544e9f594248c0c785f601a55 (diff)
downloadopenembedded-core-1018619f1b18f8045ae84d65d16becf3fe21ffe0.tar.gz
x264: update to latest revision on official git
The mirror was out of date; meanwhile x264 remains in active development. Drop unsuitable x32 patch and declare x264 incompatible with the target (by every sign it's an extinct target; if not so please work with upstream to develop a solution there). Replace don-t-default-to-cortex-a9-with-neon.patch with a configure option passing in target compiler options so that configure can make correct decisions and we don't have to patch it. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/x264/x264/Fix-X32-build-by-disabling-asm.patch51
-rw-r--r--meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch33
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb9
3 files changed, 5 insertions, 88 deletions
diff --git a/meta/recipes-multimedia/x264/x264/Fix-X32-build-by-disabling-asm.patch b/meta/recipes-multimedia/x264/x264/Fix-X32-build-by-disabling-asm.patch
deleted file mode 100644
index cb771fb0bf..0000000000
--- a/meta/recipes-multimedia/x264/x264/Fix-X32-build-by-disabling-asm.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 7bc25f4d1aaa5186d2eff3e2326c7245fcd7e7f3 Mon Sep 17 00:00:00 2001
-From: Christopher Larson <chris_larson@mentor.com>
-Date: Tue, 13 Dec 2016 14:22:32 -0700
-Subject: [PATCH] Fix X32 build by disabling asm
-
-This applies gentoo's x32 patch, adjusted slightly, which disables asm support
-for x32 as well as correcting -m.
-
-Debian has a different patch which does the same, and there's a superior yet
-out of date patch series on the x264 list which keeps asm support enabled, but
-doesn't successfully build at this time, and my assembly is very rusty.
-
-Upstream-Status: Pending
-Signed-off-by: Christopher Larson <chris_larson@mentor.com>
-
----
- configure | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/configure b/configure
-index 51b128d..6ea9469 100755
---- a/configure
-+++ b/configure
-@@ -754,7 +754,13 @@ case $host_cpu in
- AS_EXT=".asm"
- ASFLAGS="$ASFLAGS -DARCH_X86_64=1 -I\$(SRCPATH)/common/x86/"
- stack_alignment=16
-- [ $compiler = GNU ] && CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
-+ if [ $compiler = GNU ]; then
-+ if cpp_check "" "" "__ILP32__" ; then
-+ CFLAGS="-mx32 $CFLAGS" && LDFLAGS="-mx32 $LDFLAGS"
-+ else
-+ CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
-+ fi
-+ fi
- if [ "$SYS" = MACOSX ]; then
- ASFLAGS="$ASFLAGS -f macho64 -DPREFIX"
- if cc_check '' "-arch x86_64"; then
-@@ -773,7 +779,11 @@ case $host_cpu in
- RCFLAGS="--target=pe-x86-64 $RCFLAGS"
- fi
- else
-- ASFLAGS="$ASFLAGS -f elf64"
-+ if cpp_check "" "" "__ILP32__" ; then
-+ asm=no
-+ else
-+ ASFLAGS="$ASFLAGS -f elf64"
-+ fi
- fi
- ;;
- powerpc*)
diff --git a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
deleted file mode 100644
index 065e3b35b7..0000000000
--- a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From a72bf499a0674fc75eedf15008b424e28f67e4bd Mon Sep 17 00:00:00 2001
-From: Andrei Gherzan <andrei@gherzan.ro>
-Date: Fri, 2 Feb 2018 15:10:08 +0200
-Subject: [PATCH] dont default to cortex-a9 with neon
-
--march flag is not in CFLAGS so this will always default to
- -mcpu=cortex-a8 -mfpu=neon.
-
-Upstream-Status: Pending
-
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-Signed-off-by: Maxin B. John <maxin.john@intel.com>
----
- configure | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/configure b/configure
-index 0e3ef23..955b993 100755
---- a/configure
-+++ b/configure
-@@ -911,9 +911,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
- fi
-
- if [ $asm = auto -a $ARCH = ARM ] ; then
-- # set flags so neon is built by default
-- [ $compiler == CL ] || echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
--
- cc_check '' '' '__asm__("add r0, r1, r2");' && define HAVE_ARM_INLINE_ASM
- if [ $compiler = CL ] && cpp_check '' '' 'defined(_M_ARM) && _M_ARM >= 7' ; then
- define HAVE_ARMV6
---
-2.4.0
-
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
index e7d9e75e8d..fae88d24d1 100644
--- a/meta/recipes-multimedia/x264/x264_git.bb
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -8,13 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "nasm-native"
-SRC_URI = "git://github.com/mirror/x264;branch=stable;protocol=https \
- file://don-t-default-to-cortex-a9-with-neon.patch \
- file://Fix-X32-build-by-disabling-asm.patch \
+SRC_URI = "git://code.videolan.org/videolan/x264.git;branch=stable;protocol=https \
"
UPSTREAM_CHECK_COMMITS = "1"
-SRCREV = "baee400fa9ced6f5481a728138fed6e867b0ff7f"
+SRCREV = "31e19f92f00c7003fa115047ce50978bc98c3a0d"
PV = "r3039+git"
@@ -41,6 +39,7 @@ EXTRA_OECONF = '--prefix=${prefix} \
--disable-opencl \
--enable-pic \
${X264_DISABLE_ASM} \
+ --extra-cflags="${TUNE_CCARGS}" \
'
do_configure() {
@@ -54,3 +53,5 @@ do_install() {
}
AS[unexport] = "1"
+
+COMPATIBLE_HOST:x86-x32 = "null"