summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-08-02 20:02:30 +0200
committerSteve Sakoman <steve@sakoman.com>2023-08-15 08:03:07 -1000
commit3afb1edc760a7cc1048aa9ae009a8cc6d32f9e89 (patch)
tree05726fe26fab15411f569d583b1d36fd744635cb
parent814672f886b5859524dcc0c285d916a1ccca6605 (diff)
downloadopenembedded-core-3afb1edc760a7cc1048aa9ae009a8cc6d32f9e89.tar.gz
curl: ensure all ptest failures are caught
Piping results through sed is masking failures that aren't picked up by sed expressions. One such failure probes the source tree, and so isn't relevant for target testing, and can be disabled. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 86c96cbf68d986b44fdb45e988343ce29d6b8cc7) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/curl/curl/disable-tests2
-rw-r--r--meta/recipes-support/curl/curl/run-ptest2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl/disable-tests b/meta/recipes-support/curl/curl/disable-tests
index 92056bd8ca..b687b2bb76 100644
--- a/meta/recipes-support/curl/curl/disable-tests
+++ b/meta/recipes-support/curl/curl/disable-tests
@@ -18,6 +18,8 @@
1165
# This CRL test is looking for src files
1185
+# This test is scanning the source tree
+1222
# These CRL tests need --libcurl option to be enabled
1400
1401
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 614e822922..2c74c58f5d 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,6 @@
#!/bin/sh
cd tests
-./runtests.pl -a -n -s | sed \
+{ ./runtests.pl -a -n -s || echo "FAIL: curl" ; } | sed \
-e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
-e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
-e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'