summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-04-27 09:35:28 +0200
committerSteve Sakoman <steve@sakoman.com>2023-05-15 05:46:54 -1000
commit8f47d5cb79758d5b2a296759bd4806f85f739b90 (patch)
treee51d9c40625bb3ac01a2220bfbb883c0ea58eeb6
parent6578d20898f68c0cc88eda7e0f56e6f5a557f17e (diff)
downloadopenembedded-core-8f47d5cb79758d5b2a296759bd4806f85f739b90.tar.gz
perl: patch out build paths from native binaries
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 9ea0f850928b3e7d7a2eb280b8b3ed0c9f977cd6) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.36.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.36.0.bb b/meta/recipes-devtools/perl/perl_5.36.0.bb
index 4d8a919d1e..b8dba00f18 100644
--- a/meta/recipes-devtools/perl/perl_5.36.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.36.0.bb
@@ -109,6 +109,10 @@ do_configure:class-native() {
-Ui_xlocale \
-Alddlflags=' ${LDFLAGS}' \
${PACKAGECONFIG_CONFARGS}
+
+ # This prevents leakage of build paths into perl-native binaries, which
+ # causes non-deterministic troubles when those paths no longer exist or aren't accessible.
+ sed -i -e "s,${STAGING_LIBDIR},/completelyboguspath,g" config.h
}
do_configure:append() {