summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Pellegrin <fede@evolware.org>2023-02-09 17:03:08 +0100
committerSteve Sakoman <steve@sakoman.com>2023-02-25 09:25:51 -1000
commit6a4f55bb305e3cb2fb3f60471ff0adaef5adbc9f (patch)
tree1756560659b374d337794db1d01839d628ca1304
parentd64e3cf57d80f4f399350d91fc3e39198014f5eb (diff)
downloadopenembedded-core-6a4f55bb305e3cb2fb3f60471ff0adaef5adbc9f.tar.gz
curl: fix dependencies when building with ldap/ldaps
openldap is added as a dependency so the build will not fail, as otherwise ldap headers are not found during configure phase Note: due to upstream bug (now fixed) building LDAP/LDAPS support with minimal configurations can sometimes not work, see details at: https://github.com/curl/curl/pull/10445 Signed-off-by: Federico Pellegrin <fede@evolware.org> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a999f62f5692687a5557f7a50c7c768c50f3d7d3) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/curl/curl_7.85.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/curl/curl_7.85.0.bb b/meta/recipes-support/curl/curl_7.85.0.bb
index 846cdacb41..4e05434a12 100644
--- a/meta/recipes-support/curl/curl_7.85.0.bb
+++ b/meta/recipes-support/curl/curl_7.85.0.bb
@@ -46,8 +46,8 @@ PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
-PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
-PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
+PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap"
+PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,openldap"
PACKAGECONFIG[libgsasl] = "--with-libgsasl,--without-libgsasl,libgsasl"
PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"