summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-02-08 01:22:36 -0800
committerSteve Sakoman <steve@sakoman.com>2023-02-18 06:41:49 -1000
commit20231fece4b7f15bae574d89a362506f39cfd967 (patch)
tree9238fd7ab9d8c8006e1c7b39739ea4de988e2e66
parent5dab1edf6df6eaba59c3c6a996ca19213e0a4743 (diff)
downloadopenembedded-core-20231fece4b7f15bae574d89a362506f39cfd967.tar.gz
ffmpeg: fix configure failure on noexec /tmp host
The configure scripts uses /tmp to execute some generated files. If /tmp is noexec, then we meet the following error. | Unable to create and execute files in /tmp. Set the TMPDIR environment | variable to another directory and make sure that it is not mounted noexec. | Sanity test failed. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 6099b88c4decb285fd3519d5565909c15d935030) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb
index 06eca4fefe..7970740254 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb
@@ -141,6 +141,8 @@ LDFLAGS:append:x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -f
EXTRA_OEMAKE = "V=1"
do_configure() {
+ export TMPDIR="${B}/tmp"
+ mkdir -p ${B}/tmp
${S}/configure ${EXTRA_OECONF}
}