summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-10-19 10:54:50 +0800
committerSteve Sakoman <steve@sakoman.com>2022-11-04 09:16:52 -1000
commit3d4bb6b1ba41e83c98e821ddf86e231daec029b1 (patch)
tree7f4cb4c7059c24265ba2ba73bc9cd6858ad6cbe4
parentc017175deed298f7fb3fff9181eb4379fcc436d7 (diff)
downloadopenembedded-core-3d4bb6b1ba41e83c98e821ddf86e231daec029b1.tar.gz
grub: disable build on armv7ve/a with hardfp
The commit(75dbdea940 grub: Allow build on armv7ve/a with softfp) enable build on armv7ve/a with softfp, but it acutally enable build on armv7ve/a with hardfp altogether and result in below build failure: | checking for compile options to get strict alignment... -mno-unaligned-access | checking if compiler generates unaligned accesses... no | checking if C symbols get an underscore after compilation... no | checking whether target compiler is working... no | configure: error: cannot compile for the target So update the check to disable build on armv7ve/a with hardfp. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit f67b2880fc2cfb21f51216c63b5f24d0524b4278) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-bsp/grub/grub2.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub2.inc b/meta/recipes-bsp/grub/grub2.inc
index 2545b99b6a..7161c4560b 100644
--- a/meta/recipes-bsp/grub/grub2.inc
+++ b/meta/recipes-bsp/grub/grub2.inc
@@ -50,8 +50,8 @@ COMPATIBLE_HOST = "${GRUB_COMPATIBLE_HOST}"
# Grub doesn't support hard float toolchain and won't be able to forcefully
# disable it on some of the target CPUs. See 'configure.ac' for
# supported/unsupported CPUs in hardfp.
-COMPATIBLE_HOST:armv7a = "${@'null' if d.getVar('TUNE_CCARGS_MFLOAT') == 'hardfp' else d.getVar('GRUB_COMPATIBLE_HOST')}"
-COMPATIBLE_HOST:armv7ve = "${@'null' if d.getVar('TUNE_CCARGS_MFLOAT') == 'hardfp' else d.getVar('GRUB_COMPATIBLE_HOST')}"
+COMPATIBLE_HOST:armv7a = "${@'null' if bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', True, False, d) else d.getVar('GRUB_COMPATIBLE_HOST')}"
+COMPATIBLE_HOST:armv7ve = "${@'null' if bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', True, False, d) else d.getVar('GRUB_COMPATIBLE_HOST')}"
# configure.ac has code to set this automagically from the target tuple
# but the OE freeform one (core2-foo-bar-linux) don't work with that.