summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-09-20 18:15:35 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-21 09:18:58 +0100
commit636c7a68ad23dc64d3778e3718c3410691380ee9 (patch)
treec5aa27ade56c3448a82ad6af355ee9e873ef71f0
parentcf33e2ab2693eafaf0e5fc45666355d60e084281 (diff)
downloadopenembedded-core-636c7a68ad23dc64d3778e3718c3410691380ee9.tar.gz
linux-yocto/5.19: cfg: fix ACPI warnings for -tiny
Integrating the following commit(s) to linux-yocto/.: acpi: fix defaults for x86 and qemuarm64 commit d334505d98a85ffe7549026d10e43cccd897e19c [efi.cfg: Drop ACPI dependency] is generating configuration warnings on both qemuarm64 and x86 for the poky-tiny configuration. x864: - because we configure tiny with allnoconfig, and then apply our fragments, the default of ACPI=y for x86 doesn't hold. We need to exlicitly enable it. We put it in the x86 fragment, to avoid bringing warnings back for arm32 ARM: - We can't assign to ARCH_SUPPORTS_ACPI, as that is a select only value. The only selector for that config in arch/arm is CONFIG_EFI. The default of CONFIG_ACPI was added to support EFI if required, but since CONFIG_EFI takes care of the selection, we don't need it in our BSP configuration. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.19.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
index 29b7760298..17ae94066c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "3596666292dcf3fc078090666dc327d233695310"
-SRCREV_meta ?= "829511f25a4a868d33019ace607dc7f0a14d3105"
+SRCREV_meta ?= "350b544d077955b599b54ab364f6227d96a90455"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.19;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
index 65b7070e6e..c18278ad79 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
@@ -15,7 +15,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "44a446e91acea4f2f0d35896763224c3b52a3ed5"
-SRCREV_meta ?= "829511f25a4a868d33019ace607dc7f0a14d3105"
+SRCREV_meta ?= "350b544d077955b599b54ab364f6227d96a90455"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
index bafe57df0e..4fc1ae9245 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
@@ -23,7 +23,7 @@ SRCREV_machine:qemux86 ?= "44a446e91acea4f2f0d35896763224c3b52a3ed5"
SRCREV_machine:qemux86-64 ?= "44a446e91acea4f2f0d35896763224c3b52a3ed5"
SRCREV_machine:qemumips64 ?= "99613988297ac45653cc81319e63b2821645a3ba"
SRCREV_machine ?= "44a446e91acea4f2f0d35896763224c3b52a3ed5"
-SRCREV_meta ?= "829511f25a4a868d33019ace607dc7f0a14d3105"
+SRCREV_meta ?= "350b544d077955b599b54ab364f6227d96a90455"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same