summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-02-10 16:12:34 +0000
committerSteve Sakoman <steve@sakoman.com>2024-02-21 03:59:19 -1000
commit01440b4968ded30c1970c335fe1598b684527831 (patch)
tree2ecff10d63895612b34704ac584f7a34fcf56c19
parentb71eeab71911ab49a8e8b8d78560fdbd66f883e7 (diff)
downloadopenembedded-core-01440b4968ded30c1970c335fe1598b684527831.tar.gz
curl: don't enable debug builds
In oe-core 27824261 --enable-debug was added to the configure arguments to turn on debugging symbols. However, enabling debug mode does more than turn on debugging symbols and introduces some codepaths that can be controlled with environment variables. Bluntly, the curl maintainer says that --enable-debug should not be used in production: https://curl.se/mail/lib-2023-01/0039.html I did a build and verified that the curl-dbg package doesn't massively shrink, so the debug symbols are still being built. Remove the debug options and hide them behind a PACKAGECONFIG, with a comment that it should not be used in production. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/curl/curl_7.82.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/curl/curl_7.82.0.bb b/meta/recipes-support/curl/curl_7.82.0.bb
index de69d3d53b..383cf415d9 100644
--- a/meta/recipes-support/curl/curl_7.82.0.bb
+++ b/meta/recipes-support/curl/curl_7.82.0.bb
@@ -79,6 +79,8 @@ PACKAGECONFIG:class-nativesdk = "ipv6 openssl proxy random threaded-resolver ver
PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
+# Don't use this in production
+PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
@@ -115,9 +117,7 @@ EXTRA_OECONF = " \
--enable-crypto-auth \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
--without-libpsl \
- --enable-debug \
--enable-optimize \
- --disable-curldebug \
${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \
"