summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZqiang <qiang.zhang@windriver.com>2021-08-03 13:11:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-05 08:51:17 +0100
commit5a268f95a5bf5ee8c244a8af685d6c84aad9a4ac (patch)
tree96acd04302f418718222ec2a81af9aa2812d4855
parent54368f1b02e1ac4aa068515730a8c8bcd3683eb3 (diff)
downloadopenembedded-core-5a268f95a5bf5ee8c244a8af685d6c84aad9a4ac.tar.gz
python3: use monotonic clock for condvar if possible
The timeout for threading.Lock, threading.Condition, etc, is not using a monotonic clock, it is affected if the system time (realtime clock) is set. This patch will make condvar use monotonic clock. Refence: https://bugs.python.org/issue41710 Signed-off-by: Zqiang <qiang.zhang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.9.6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.9.6.bb b/meta/recipes-devtools/python/python3_3.9.6.bb
index 9fe8e03389..34500642d4 100644
--- a/meta/recipes-devtools/python/python3_3.9.6.bb
+++ b/meta/recipes-devtools/python/python3_3.9.6.bb
@@ -74,6 +74,9 @@ DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/li
DEPENDS:append:class-target = " python3-native"
DEPENDS:append:class-nativesdk = " python3-native"
+# force to use the mutex+cond implementation (https://bugs.python.org/issue41710)
+CFLAGS += "-DHAVE_BROKEN_POSIX_SEMAPHORES"
+
EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"