summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-05-17 12:58:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-18 23:52:49 +0100
commit365f0804a0726fe4be9eb7ef3515fea2dd38bef1 (patch)
treef343b2c3d1c3144aad5620cb9810e4fef8e8e87f
parent8d6be1b9914186bca2552ae03bf9bd35ecbffeec (diff)
downloadopenembedded-core-365f0804a0726fe4be9eb7ef3515fea2dd38bef1.tar.gz
rpm: turn Berkeley DB hard dependency into PACKAGECONFIG
In the future we hope to switch to sqlite instead of Berkeley DB, so prepare for this by adding an (enabled by default) PACKAGECONFIG for Berkeley DB. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.16.1.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.16.1.3.bb b/meta/recipes-devtools/rpm/rpm_4.16.1.3.bb
index 2857cd730c..f9c04cf680 100644
--- a/meta/recipes-devtools/rpm/rpm_4.16.1.3.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.16.1.3.bb
@@ -51,7 +51,7 @@ S = "${WORKDIR}/git"
# included in 4.16.1.3
CVE_CHECK_WHIETLIST += "CVE-2021-20271"
-DEPENDS = "libgcrypt db file popt xz bzip2 elfutils python3"
+DEPENDS = "libgcrypt file popt xz bzip2 elfutils python3"
DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
inherit autotools gettext pkgconfig python3native
@@ -74,11 +74,12 @@ EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
BBCLASSEXTEND = "native nativesdk"
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
+PACKAGECONFIG ??= "bdb ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
# The inhibit plugin serves no purpose outside of the target
PACKAGECONFIG_remove_class-native = "inhibit"
PACKAGECONFIG_remove_class-nativesdk = "inhibit"
+PACKAGECONFIG[bdb] = "--enable-bdb,--disable-bdb,db"
PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"