summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:00 -0800
commit7ae4ce08071c02beaf09675c2c1ed70617b797dd (patch)
treeeac6f8230be9bab9324bc9e3a7f0275c43928b20
parentca9c8fe634ca91fe1825fae7ebb0d00021ca480b (diff)
downloadopenembedded-core-7ae4ce08071c02beaf09675c2c1ed70617b797dd.tar.gz
libffi: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libffi/libffi/not-win32.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta/recipes-support/libffi/libffi/not-win32.patch b/meta/recipes-support/libffi/libffi/not-win32.patch
index 1e90125edd..80c40a4742 100644
--- a/meta/recipes-support/libffi/libffi/not-win32.patch
+++ b/meta/recipes-support/libffi/libffi/not-win32.patch
@@ -11,12 +11,16 @@ As this block is generally pointless, disable it.
Upstream-Status: Inappropriate
Signed-off-by: Ross Burton <ross.burton@intel.com>
---- a/configure.ac~ 2014-11-12 11:56:51.000000000 +0000
-+++ b/configure.ac 2016-02-04 14:02:53.765710532 +0000
-@@ -593,5 +593,5 @@
+Index: libffi-3.2.1/configure.ac
+===================================================================
+--- libffi-3.2.1.orig/configure.ac
++++ libffi-3.2.1/configure.ac
+@@ -592,7 +592,7 @@ AC_ARG_ENABLE(purify-safety,
+
# These variables are only ever used when we cross-build to X86_WIN32.
# And we only support this with GCC, so...
-if test "x$GCC" = "xyes"; then
+if false; then
if test -n "$with_cross_host" &&
- test x"$with_cross_host" != x"no"; then \ No newline at end of file
+ test x"$with_cross_host" != x"no"; then
+ toolexecdir="${exec_prefix}"/'$(target_alias)'