summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLans Zhang <jia.zhang@windriver.com>2017-07-27 14:03:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-27 09:21:48 +0100
commit9d7797e4374c111f0dff523fd49354bcc33dc2af (patch)
tree25df3593b1b1fa9e211d51b217a4bf5928759eda
parentd0ebcf62109d6a131e02cd4c0f04bba203ed6579 (diff)
downloadopenembedded-core-9d7797e4374c111f0dff523fd49354bcc33dc2af.tar.gz
rpm: allow to enable RPM file signing
RPM file signing is enabled with --with-imaevm during configuration. If enabled, the RPM signing tool rpmsign will call libimaevm.so provided by the recipe ima-evm-utils. Signed-off-by: Lans Zhang <jia.zhang@windriver.com> Signed-off-by: Jia Zhang <lans.zhang2008@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index 2a0dcafac7..d9ff2c7fa5 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -71,6 +71,9 @@ EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --di
BBCLASSEXTEND = "native nativesdk"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
+
# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
# libmagic also has sysroot path contamination, so override it
do_install_append_class-native() {