aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2017-01-04 15:57:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-05 13:53:44 +0000
commit930c5a17b543bef9d5c2efe71680f82993d77269 (patch)
tree78e855940eefdc36948646da40420ba9a9fd9a15
parent2ed46ada4b8e496493835e84b36f7e9c367f59d2 (diff)
downloadopenembedded-core-930c5a17b543bef9d5c2efe71680f82993d77269.tar.gz
waffle: add opengl to REQUIRED_DISTRO_FEATURES
Multiple packageconfigs depend upon virtual/libgl, whose providers require the opengl distro feature. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.5.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.5.2.bb b/meta/recipes-graphics/waffle/waffle_1.5.2.bb
index f7db1bc955..9d6b0e0e0d 100644
--- a/meta/recipes-graphics/waffle/waffle_1.5.2.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.5.2.bb
@@ -20,6 +20,9 @@ PACKAGECONFIG ??= "glx"
# libx11 requires x11 in DISTRO_FEATURES.
REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
+# virtual/libgl requires opengl in DISTRO_FEATURES.
+REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/libgl', 'opengl', '', d)}"
+
# I say virtual/libgl, actually wants gl.pc
PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/libgl libx11"