aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-05-31 16:27:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-30 08:45:11 +0100
commit5b1454304483a0bc725b32fd5458e5281c68112f (patch)
tree780108085556c0c97b3d389ae84bd91b10c37d24
parent56f6fc7d6de0a46046ea2abcc392b1da88e398ec (diff)
downloadopenembedded-core-5b1454304483a0bc725b32fd5458e5281c68112f.tar.gz
siteinfo: fix siteinfo_get_files to work with RSS
The siteconfig cache files in ACLOCALDIR setup by autotools.bbclass has been dropped after switching to RSS, so change the siteconfig search path back to SITECONFIG_SYSROOTCACHE and the parameter name changed from aclocalcache to sysrootcache. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/autotools.bbclass2
-rw-r--r--meta/classes/siteinfo.bbclass15
2 files changed, 5 insertions, 12 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index ac04a07cb5..efa4098d63 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -141,7 +141,7 @@ ACLOCALEXTRAPATH_class-nativesdk = " -I ${STAGING_DATADIR_NATIVE}/aclocal/"
python autotools_aclocals () {
# Refresh variable with cache files
- d.setVar("CONFIG_SITE", siteinfo_get_files(d, aclocalcache=True))
+ d.setVar("CONFIG_SITE", siteinfo_get_files(d, sysrootcache=True))
}
CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"
diff --git a/meta/classes/siteinfo.bbclass b/meta/classes/siteinfo.bbclass
index 20b4704f1c..1aada40695 100644
--- a/meta/classes/siteinfo.bbclass
+++ b/meta/classes/siteinfo.bbclass
@@ -153,7 +153,7 @@ python () {
bb.fatal("Please add your architecture to siteinfo.bbclass")
}
-def siteinfo_get_files(d, aclocalcache = False):
+def siteinfo_get_files(d, sysrootcache = False):
sitedata = siteinfo_data(d)
sitefiles = ""
for path in d.getVar("BBPATH").split(":"):
@@ -162,18 +162,11 @@ def siteinfo_get_files(d, aclocalcache = False):
if os.path.exists(filename):
sitefiles += filename + " "
- if not aclocalcache:
+ if not sysrootcache:
return sitefiles
- # Now check for siteconfig cache files in the directory setup by autotools.bbclass to
- # avoid races.
- #
- # ACLOCALDIR may or may not exist so cache should only be set to True from autotools.bbclass
- # after files have been copied into this location. To do otherwise risks parsing/signature
- # issues and the directory being created/removed whilst this code executes. This can happen
- # when a multilib recipe is parsed along with its base variant which may be running at the time
- # causing rare but nasty failures
- path_siteconfig = d.getVar('ACLOCALDIR')
+ # Now check for siteconfig cache files in sysroots
+ path_siteconfig = d.getVar('SITECONFIG_SYSROOTCACHE')
if path_siteconfig and os.path.isdir(path_siteconfig):
for i in os.listdir(path_siteconfig):
if not i.endswith("_config"):