aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2017-01-04 15:57:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-05 13:53:44 +0000
commit009c088f6d0bf75ebb17825f6a3aba356a5b659d (patch)
tree536f1059e40764c4248309a8bf1f33b240c394bf
parent930c5a17b543bef9d5c2efe71680f82993d77269 (diff)
downloadopenembedded-core-009c088f6d0bf75ebb17825f6a3aba356a5b659d.tar.gz
piglit: add opengl to REQUIRED_DISTRO_FEATURES
This recipe depend on virtual/libgl, whose providers require the opengl distro feature. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 82adcdeca1..b9cdce8307 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -22,6 +22,9 @@ inherit cmake python3native distro_features_check bash-completion
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
+# depends on virtual/libgl
+REQUIRED_DISTRO_FEATURES += "opengl"
+
# The built scripts go into the temporary directory according to tempfile
# (typically /tmp) which can race if multiple builds happen on the same machine,
# so tell it to use a directory in ${B} to avoid overwriting.