aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-04-15 14:23:12 +0000
committerRichard Purdie <richard@openedhand.com>2008-04-15 14:23:12 +0000
commita8ed0612613bc284cdf097ac211b9022738c8ae1 (patch)
treeb9293ee5f64a3c1d236af0e5241b074f828a8ce1
parentfe074c7bc5c971f601275b961957e9fdf4af1fc3 (diff)
downloadopenembedded-core-a8ed0612613bc284cdf097ac211b9022738c8ae1.tar.gz
gettext: Backport updated macros from gettext 0.17 to avoid conflicts with libtool
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4272 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/gettext/gettext-native_0.14.1.bb7
-rw-r--r--meta/packages/gettext/gettext_0.14.1.bb10
2 files changed, 16 insertions, 1 deletions
diff --git a/meta/packages/gettext/gettext-native_0.14.1.bb b/meta/packages/gettext/gettext-native_0.14.1.bb
index 6203b1f9d7..37549dbdad 100644
--- a/meta/packages/gettext/gettext-native_0.14.1.bb
+++ b/meta/packages/gettext/gettext-native_0.14.1.bb
@@ -50,4 +50,11 @@ do_stage_append() {
fi
install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i
done
+
+ # config.rpath is needed by some configure macros and needs to be autoinstalled.
+ # automake will do this but config.rpath needs to be visible to automake
+ for i in `ls -d ${STAGING_DATADIR}/automake*`
+ do
+ cp ${STAGING_DATADIR}/gettext/config.rpath $i
+ done
}
diff --git a/meta/packages/gettext/gettext_0.14.1.bb b/meta/packages/gettext/gettext_0.14.1.bb
index 7bc011f494..5ad2059615 100644
--- a/meta/packages/gettext/gettext_0.14.1.bb
+++ b/meta/packages/gettext/gettext_0.14.1.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "The GNU internationalization library."
HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
SECTION = "libs"
LICENSE = "GPL"
-PR = "r8"
+PR = "r10"
PROVIDES = "virtual/libintl"
SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
file://gettext-vpath.patch;patch=1;pnum=1 \
file://fixchicken.patch;patch=1;pnum=1 \
+ file://linklib_from_0.17.patch;patch=1 \
file://getline.m4.patch;patch=1 \
file://disable_java.patch;patch=1"
@@ -30,4 +31,11 @@ do_configure_prepend() {
do_stage () {
autotools_stage_all
+
+ # config.rpath is needed by some configure macros and needs to be autoinstalled.
+ # automake will do this but config.rpath needs to be visible to automake
+ for i in `ls -d ${STAGING_DATADIR}/automake*`
+ do
+ cp ${STAGING_DATADIR}/gettext/config.rpath $i
+ done
}