summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-04 15:54:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-06 08:41:21 +0100
commit231c99728da9d81c9430a2aa62239ce28734ef4a (patch)
treebe3c0d0b74f28f8818043f889c070b9ed285b4eb
parentfdeee94fa78f91613850500b209b75a6608241d0 (diff)
downloadopenembedded-core-231c99728da9d81c9430a2aa62239ce28734ef4a.tar.gz
Revert "perl: fix startperl configuration option for perl-native"
This reverts commit f2d1523b19cb066a4a06609f036822fe4a8b43f0. We've reports of a number of failures from this, it causes pod2man to reference full paths to perl rather than nativeperl from the environment. I've also seen this issue locally now. Revert until we can find a solution which works for everyone. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.1.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.1.bb b/meta/recipes-devtools/perl/perl_5.32.1.bb
index 73d66f6656..b28040c7fb 100644
--- a/meta/recipes-devtools/perl/perl_5.32.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.1.bb
@@ -95,7 +95,6 @@ do_configure_class-nativesdk() {
do_configure_class-native() {
./configure --prefix=${prefix} \
-Dbin=${bindir}/perl-native \
- -Dperlpath=${bindir}/perl-native/perl \
-Duseshrplib \
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
@@ -172,8 +171,8 @@ do_install_append_class-native () {
create_wrapper ${D}${bindir}/perl-native/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl5/site_perl/${PV}:${STAGING_LIBDIR}/perl5/vendor_perl/${PV}:${STAGING_LIBDIR}/perl5/${PV}'
# Use /usr/bin/env nativeperl for the perl script.
- for f in `grep -Il '#! *${bindir}/perl-native.*/perl' ${D}/${bindir}/*`; do
- sed -i -e 's|${bindir}/perl-native.*/perl|/usr/bin/env nativeperl|' $f
+ for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
+ sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
done
}