summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-05-03 18:10:40 +0100
committerAnuj Mittal <anuj.mittal@intel.com>2021-05-06 10:09:38 +0800
commit0eeb4dd1e9dbbbe205ff9821a398c44d5769f798 (patch)
tree6d5949d84dbf963701ca1339f8717b54b017e509
parent56f948329e2780ce8845646b0bb499d82e197d85 (diff)
downloadopenembedded-core-0eeb4dd1e9dbbbe205ff9821a398c44d5769f798.tar.gz
ptest-runner: libgcc must be installed for pthread_cancel to work
This only affects glibc systems and have been found on runqemu core-image-minimal with gstreamer ptest-runner STOP: ptest-runner libgcc_s.so.1 must be installed for pthread_cancel to work Aborted Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1cb679e6a4528a2cef16f65342d5e65adb14cb16) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
index 57a3ae005b..6bd10d2fec 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
@@ -26,3 +26,5 @@ do_compile () {
do_install () {
install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
}
+
+RDEPENDS_${PN}_append_libc-glibc = " libgcc"