summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-02-22 09:21:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-10 00:24:18 +0000
commit57af8ed4d3f1645d9a648ae1e569c792d9bcb361 (patch)
tree7b07e3fb068489aca60a89511b66235f40eaf511
parent4fd20fa9c49019b039c5e39d6ed5c9b67732ce15 (diff)
downloadopenembedded-core-57af8ed4d3f1645d9a648ae1e569c792d9bcb361.tar.gz
python3: Fix python interpreter line length for nativesdk
Make sure the python interpreter is "#!/usr/bin/env python3" for nativesdk to avoid the shebang path exceeding the limit when install the sdk under the directory with long path. Before: $ cd ${target_sdk_dir} $ vi ./sysroots/x86_64-oesdk-linux/usr/bin/2to3 #!${target_sdk_dir}/sysroots/${SDK_SYS}/usr/bin/python3.9 [snip] After: $ cd ${target_sdk_dir} $ vi ./sysroots/x86_64-oesdk-linux/usr/bin/2to3 #!/usr/bin/env python3 [snip] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a748e6098fa7d2ff594319937c7e0cf97700e83a) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.8.5.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.8.5.bb b/meta/recipes-devtools/python/python3_3.8.5.bb
index fb066084bf..fda35a31e2 100644
--- a/meta/recipes-devtools/python/python3_3.8.5.bb
+++ b/meta/recipes-devtools/python/python3_3.8.5.bb
@@ -169,6 +169,10 @@ do_install_append() {
}
do_install_append_class-nativesdk () {
+ # Make sure we use /usr/bin/env python
+ for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
+ done
create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
}