aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-08-31 22:19:37 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:47 +0100
commit8289cd417045966c13f3053e27912684a2a15180 (patch)
treea5213190d2ab5bdb8cade7a7c2a14ee990e30e80
parent93914e120cabb06f40c26ff58480b9dead0b66e3 (diff)
downloadopenembedded-core-8289cd417045966c13f3053e27912684a2a15180.tar.gz
mdadm: add the latest version 3.1.4
The recipe is borrowed from OE, with the following changes: - upgrade the version from 2.5 to 3.1.4 - simplify DESCRIPTION - add HOMEPAGE, BUGTRACKER, LICENSE and LIC_FILES_CHKSUM, PR - remove INHIBIT_AUTO_STAGE - fixing coding style issue: 4 SPACES --> 1 TAB mdadm: move to recipes-extended Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Saul Wold <Saul.Wold@intel.com>
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.1.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.1.4.bb b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
new file mode 100644
index 0000000000..b28e96b759
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = " A tool for managing Soft RAID under Linux"
+HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
+BUGTRACKER = "n/a"
+
+#A few files are GPLv2+ while most files are GPLv2.
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+ file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
+ file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
+
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2"
+
+CFLAGS += "-fno-strict-aliasing"
+
+inherit autotools
+
+do_compile() {
+ export CROSS_COMPILE="${TARGET_PREFIX}"
+ oe_runmake
+}
+
+do_install() {
+ export STRIP=""
+ autotools_do_install
+}
+