summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-12 11:41:41 +0100
committerSteve Sakoman <steve@sakoman.com>2021-10-19 04:04:49 -1000
commite570efa43d5655afa041bd4ab52fec2de2216e4d (patch)
treee349ccd8d922bb2036b4e6632a517aa0a75bd47f
parente30c2be8b9534a8dbec5520b41a00c6dc8aa65a4 (diff)
downloadopenembedded-core-e570efa43d5655afa041bd4ab52fec2de2216e4d.tar.gz
libxml2: Use python3targetconfig to fix reproducibility issue
We're seeing pthread being linked sometimes and not others leading to non-reproducible target binaries. The reason is mixing the native python config with the target one. We should use the target one. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1bc5378db760963e2ad46542f2907dd6a592eb66) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.10.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.10.bb b/meta/recipes-core/libxml/libxml2_2.9.10.bb
index 60dc71f38d..ebb996c8dd 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.10.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.10.bb
@@ -44,7 +44,7 @@ PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
inherit autotools pkgconfig binconfig-disabled ptest features_check
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
RDEPENDS_${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"