summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi Wang <li.wang@windriver.com>2021-03-12 17:52:50 +0800
committerSteve Sakoman <steve@sakoman.com>2021-03-24 04:30:32 -1000
commit9d166adde55ce8f0ba60c37c0679a99c947b2779 (patch)
treea484463ab0687d8273e79b38aa828b36a167c88c
parent92b2da5824c11063d0bb8e39bc221530137e29b4 (diff)
downloadopenembedded-core-9d166adde55ce8f0ba60c37c0679a99c947b2779.tar.gz
linux-dummy: add empty dependent packages
some kernel includes kernel-image-image and kernel-devicetree packages. these patckages are defined in kernel.bbclass but, when use linux-dummy, these packages are not defined. so, define them as empty packages for avoiding compile error: ERROR: Nothing RPROVIDES 'kernel-devicetree' Signed-off-by: Li Wang <li.wang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 8dbae2dd5ac3de629957ca699f823f5438e80163) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/classes/linux-dummy.bbclass26
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb2
2 files changed, 27 insertions, 1 deletions
diff --git a/meta/classes/linux-dummy.bbclass b/meta/classes/linux-dummy.bbclass
new file mode 100644
index 0000000000..cd8791557d
--- /dev/null
+++ b/meta/classes/linux-dummy.bbclass
@@ -0,0 +1,26 @@
+
+python __anonymous () {
+ if d.getVar('PREFERRED_PROVIDER_virtual/kernel') == 'linux-dummy':
+ # copy part codes from kernel.bbclass
+ kname = d.getVar('KERNEL_PACKAGE_NAME') or "kernel"
+
+ # set an empty package of kernel-devicetree
+ d.appendVar('PACKAGES', ' %s-devicetree' % kname)
+ d.setVar('ALLOW_EMPTY_%s-devicetree' % kname, '1')
+
+ # Merge KERNEL_IMAGETYPE and KERNEL_ALT_IMAGETYPE into KERNEL_IMAGETYPES
+ type = d.getVar('KERNEL_IMAGETYPE') or ""
+ alttype = d.getVar('KERNEL_ALT_IMAGETYPE') or ""
+ types = d.getVar('KERNEL_IMAGETYPES') or ""
+ if type not in types.split():
+ types = (type + ' ' + types).strip()
+ if alttype not in types.split():
+ types = (alttype + ' ' + types).strip()
+
+ # set empty packages of kernel-image-*
+ for type in types.split():
+ typelower = type.lower()
+ d.appendVar('PACKAGES', ' %s-image-%s' % (kname, typelower))
+ d.setVar('ALLOW_EMPTY_%s-image-%s' % (kname, typelower), '1')
+}
+
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index 95dc85ff2f..c56f8990de 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
PROVIDES += "virtual/kernel"
-inherit deploy
+inherit deploy linux-dummy
PACKAGES_DYNAMIC += "^kernel-module-.*"
PACKAGES_DYNAMIC += "^kernel-image-.*"