summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2020-07-16 14:56:32 +0800
committerSteve Sakoman <steve@sakoman.com>2020-07-23 04:07:37 -1000
commit4e0d1bdc6e896c7dedccf615d6d0da9eb91d9b1d (patch)
tree7f5ac91567f0e26065503521018cebacc2bbdcb2
parent66f9db48bb9d59f08492f0515bc08b6b039aa03f (diff)
downloadopenembedded-core-4e0d1bdc6e896c7dedccf615d6d0da9eb91d9b1d.tar.gz
rpm: fix nativesdk's default var location
For now, the nativesdk-rpm's %_var in /usr/lib/rpm/macros is '/var'. This is causing error when running `rpm -qplv A.rpm'. error: cannot open Packages index using db5 - Permission denied (13) error: cannot open Packages database in /var/lib/rpm The rpm in SDK should be using its own database. So we should remove this configure option, letting the SDK's native sysroot prefix to be there in %_var. In fact, '%_usr' in macros has already got the prefix. After this change, we have in the macros file lines like below. """ %_usr /opt/windriver/wrlinux/20.29/sysroots/x86_64-wrlinuxsdk-linux/usr %_usrsrc %{_usr}/src %_var /opt/windriver/wrlinux/20.29/sysroots/x86_64-wrlinuxsdk-linux/var """ Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 13e17930062cb3f816516ba7dbeb70d6da7174dd) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.2.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
index 17255dc87a..4029217d08 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
@@ -70,7 +70,7 @@ EXTRA_OECONF_append_libc-musl = " --disable-nls"
# Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled.
# Also disable plugins by default for native.
EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
-EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
+EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
BBCLASSEXTEND = "native nativesdk"