aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-10-02 23:24:10 -0400
committerScott Garman <scott.a.garman@intel.com>2012-10-04 09:08:16 -0700
commitc15fae372cf75403facc28cf76f973b1279425dd (patch)
tree646a4bfe8c8a0ec9fdf49b7632fafef4d8ccbb96
parent7c7dcb05685d840c70474d409f6a58ae459c46f0 (diff)
downloadopenembedded-core-c15fae372cf75403facc28cf76f973b1279425dd.tar.gz
openssl: add deprecated and unmaintained find.pl from perl-5.14 to fix perlpath.pl
* openembedded-core/meta/recipes-connectivity/openssl/openssl.inc * * is using perlpath.pl: * * do_configure () { * cd util * perl perlpath.pl ${STAGING_BINDIR_NATIVE} * ... * * and perlpath.pl is using find.pl: * openssl-1.0.0i/util/perlpath.pl: * #!/usr/local/bin/perl * # * # modify the '#!/usr/local/bin/perl' * # line in all scripts that rely on perl. * # * * require "find.pl"; * ... * * which was removed in perl-5.16.0 and marked as deprecated and * unmaintained in 5.14 and older: * /tmp/usr/lib/perl5/5.14.2/find.pl: * warn "Legacy library @{[(caller(0))[6]]} will be removed from the Perl * core distribution in the next major release. Please install it from the * CPAN distribution Perl4::CoreLibs. It is being used at @{[(caller)[1]]}, * line @{[(caller)[2]]}.\n"; * * # This library is deprecated and unmaintained. It is included for * # compatibility with Perl 4 scripts which may use it, but it will be * # removed in a future version of Perl. Please use the File::Find module * # instead. (from OE-Core rev c09bf5d177a7ecd2045ef7e13fff4528137a9775) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl-1.0.0i/find.pl54
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.0i.bb7
2 files changed, 60 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.0i/find.pl b/meta/recipes-connectivity/openssl/openssl-1.0.0i/find.pl
new file mode 100644
index 0000000000..8e1b42c88a
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-1.0.0i/find.pl
@@ -0,0 +1,54 @@
+warn "Legacy library @{[(caller(0))[6]]} will be removed from the Perl core distribution in the next major release. Please install it from the CPAN distribution Perl4::CoreLibs. It is being used at @{[(caller)[1]]}, line @{[(caller)[2]]}.\n";
+
+# This library is deprecated and unmaintained. It is included for
+# compatibility with Perl 4 scripts which may use it, but it will be
+# removed in a future version of Perl. Please use the File::Find module
+# instead.
+
+# Usage:
+# require "find.pl";
+#
+# &find('/foo','/bar');
+#
+# sub wanted { ... }
+# where wanted does whatever you want. $dir contains the
+# current directory name, and $_ the current filename within
+# that directory. $name contains "$dir/$_". You are cd'ed
+# to $dir when the function is called. The function may
+# set $prune to prune the tree.
+#
+# For example,
+#
+# find / -name .nfs\* -mtime +7 -exec rm -f {} \; -o -fstype nfs -prune
+#
+# corresponds to this
+#
+# sub wanted {
+# /^\.nfs.*$/ &&
+# (($dev,$ino,$mode,$nlink,$uid,$gid) = lstat($_)) &&
+# int(-M _) > 7 &&
+# unlink($_)
+# ||
+# ($nlink || (($dev,$ino,$mode,$nlink,$uid,$gid) = lstat($_))) &&
+# $dev < 0 &&
+# ($prune = 1);
+# }
+#
+# Set the variable $dont_use_nlink if you're using AFS, since AFS cheats.
+
+use File::Find ();
+
+*name = *File::Find::name;
+*prune = *File::Find::prune;
+*dir = *File::Find::dir;
+*topdir = *File::Find::topdir;
+*topdev = *File::Find::topdev;
+*topino = *File::Find::topino;
+*topmode = *File::Find::topmode;
+*topnlink = *File::Find::topnlink;
+
+sub find {
+ &File::Find::find(\&wanted, @_);
+}
+
+1;
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb
index ca15a3843e..c233ba1546 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb
@@ -6,7 +6,7 @@ DEPENDS += "ocf-linux"
CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
@@ -29,6 +29,7 @@ SRC_URI += "file://configure-targets.patch \
file://debian/no-symbolic.patch \
file://debian/debian-targets.patch \
file://openssl_fix_for_x32.patch \
+ file://find.pl \
"
SRC_URI[md5sum] = "b4df9c11af454fd68178c85a1d5f328f"
@@ -43,3 +44,7 @@ FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
PARALLEL_MAKEINST = ""
+
+do_configure_prepend() {
+ cp ${WORKDIR}/find.pl ${S}/util/find.pl
+}