aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-09-06 21:11:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-10 15:55:51 +0100
commite1a3ff7d455889e4c6b899227e8ca1919a443b22 (patch)
tree2e1c2c479f0a75fe67a30d2ddb894430f253e1bb
parentdf6943c29c0d31a78b0b2954dfe8ee6b97cefffe (diff)
downloadopenembedded-core-e1a3ff7d455889e4c6b899227e8ca1919a443b22.tar.gz
kmod: avoid parallel-tests
Avoid parallel-tests for kmod as it remove buildtest-TESTS and runtest-TESTS targets required by ptest. Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/kmod/kmod.inc1
-rw-r--r--meta/recipes-kernel/kmod/kmod/remove_parallel_tests.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod.inc b/meta/recipes-kernel/kmod/kmod.inc
index 1728a4e080..633258b05e 100644
--- a/meta/recipes-kernel/kmod/kmod.inc
+++ b/meta/recipes-kernel/kmod/kmod.inc
@@ -19,6 +19,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git \
file://depmod-search.conf \
file://run-ptest \
file://ptest.patch \
+ file://remove_parallel_tests.patch \
"
SRCREV = "3b38c7fcb58be4ddc34f90454c5f5dc3693d2d85"
diff --git a/meta/recipes-kernel/kmod/kmod/remove_parallel_tests.patch b/meta/recipes-kernel/kmod/kmod/remove_parallel_tests.patch
new file mode 100644
index 0000000000..ee1942806b
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod/remove_parallel_tests.patch
@@ -0,0 +1,18 @@
+Avoid parallel-tests as it remove
+buildtest-TESTS and runtest-TESTS targets
+
+Signed-off-by: Tudor Florea <tudor.florea@enea.com>
+Upstream-Status: Inappropriate (disable feature incompatible with ptest)
+
+diff -ruN a/configure.ac b/configure.ac
+--- a/configure.ac 2013-09-02 15:05:18.662366800 +0200
++++ b/configure.ac 2013-09-02 15:05:49.557066764 +0200
+@@ -8,7 +8,7 @@
+ AC_CONFIG_SRCDIR([libkmod/libkmod.c])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([check-news foreign 1.11 silent-rules
+- tar-pax no-dist-gzip dist-xz subdir-objects color-tests parallel-tests])
++ tar-pax no-dist-gzip dist-xz subdir-objects color-tests])
+ AC_PROG_CC_STDC
+ AC_USE_SYSTEM_EXTENSIONS
+ AC_SYS_LARGEFILE