aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-26 21:47:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-27 10:51:29 +0100
commitc888857b060f04b8689f393ec2d77a950da40f5a (patch)
tree77109fc78d80155b7467fcd2f676ca114a3c3271
parent6357657ec5b5687defaf1acdd94c1cf89aa06541 (diff)
downloadopenembedded-core-c888857b060f04b8689f393ec2d77a950da40f5a.tar.gz
linux-yocto: add bc-native dependency, and move to linux-yocto.inc
As reported by Martin Jansa <martin.jansa@gmail.com>, the following error happens when building in a minimal environment: | BC kernel/timeconst.h | /bin/sh: bc: command not found | make[3]: *** [kernel/timeconst.h] Error 127 | make[2]: *** [kernel] Error 2 | make[2]: *** Waiting for unfinished jobs.... kernel commit 70730bca [kernel: Replace timeconst.pl with a bc script] added a kernel dependency on bc. To support the build of linux-yocto recipes in these configurations, we add bc-native to the common dependencies. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb3
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc2
2 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
index 1c2ad37fe7..2a30b82b0d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -1,8 +1,5 @@
require recipes-kernel/linux/linux-yocto.inc
-# We need lzma (as CONFIG_KERNEL_LZMA=y)
-DEPENDS += "xz-native"
-
KBRANCH_DEFAULT = "standard/tiny/base"
KBRANCH = "${KBRANCH_DEFAULT}"
LINUX_KERNEL_TYPE = "tiny"
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 973970d62a..2bee042775 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
INC_PR = "r4"
+DEPENDS += "xz-native bc-native"
+
# A KMACHINE is the mapping of a yocto $MACHINE to what is built
# by the kernel. This is typically the branch that should be built,
# and it can be specific to the machine or shared