aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhangle Yang <zhangle.yang@windriver.com>2013-08-22 15:42:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:42:10 +0100
commitc10435025f5c51c4827d71af82a9a517f5f8f6d8 (patch)
tree38ed058fc0f721124a8e48824f12afe3f354bf5c
parentace40e1dfcaca2aa1eae2daf29c812291063fbff (diff)
downloadopenembedded-core-c10435025f5c51c4827d71af82a9a517f5f8f6d8.tar.gz
stat: fix the wrong return code
After stat -h is executed, the return code is 1. This patch changes it to 0. Signed-off-by: Zhangle Yang <zhangle.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-extended/stat/stat-3.3/fix-error-return.patch16
-rw-r--r--meta/recipes-extended/stat/stat_3.3.bb3
2 files changed, 18 insertions, 1 deletions
diff --git a/meta/recipes-extended/stat/stat-3.3/fix-error-return.patch b/meta/recipes-extended/stat/stat-3.3/fix-error-return.patch
new file mode 100644
index 0000000000..032995db8f
--- /dev/null
+++ b/meta/recipes-extended/stat/stat-3.3/fix-error-return.patch
@@ -0,0 +1,16 @@
+This patch fixies the wrong return code of stat -h.
+
+Upstream-Status: Pending
+Signed-off-by: Zhangle Yang <zhangle.yang@windriver.com>
+
+--- stat-3.3/stat.c.orig 2013-08-22 10:49:45.000000000 +0800
++++ stat-3.3/stat.c 2013-08-22 10:50:31.000000000 +0800
+@@ -845,7 +845,7 @@
+ fprintf(stderr, "\t\t%%S - Security ID in SE-Linux\n");
+ fprintf(stderr, "\t\t%%C - Security context in SE-Linux\n");
+ fprintf(stderr, "\t\t%%d - Free file nodes in file system\n");
+- exit(1);
++ exit(0);
+ }
+
+
diff --git a/meta/recipes-extended/stat/stat_3.3.bb b/meta/recipes-extended/stat/stat_3.3.bb
index 73e0873f81..1131bdf6f7 100644
--- a/meta/recipes-extended/stat/stat_3.3.bb
+++ b/meta/recipes-extended/stat/stat_3.3.bb
@@ -8,7 +8,8 @@ BBCLASSEXTEND = "native"
PR = "r0"
-SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-3.3.tar.gz"
+SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-3.3.tar.gz \
+ file://fix-error-return.patch"
SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"