aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-09-11 21:30:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-11 23:22:47 +0100
commit975412f446066215a94be78a7f7e1db9e28ebbbf (patch)
treef62ee8d8e2172905514bb9f509f182a665c7b324
parent4995acafc139107c2323da69eca718009384efe4 (diff)
downloadopenembedded-core-975412f446066215a94be78a7f7e1db9e28ebbbf.tar.gz
xf86-video-intel: disable DRI2 tests if no DRI2 is available
Somehow this slipped past the initial testing and can cause build errors in non-GL distros. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel/disable-dri2-tests.patch50
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.13.bb2
2 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel/disable-dri2-tests.patch b/meta/recipes-graphics/xorg-driver/xf86-video-intel/disable-dri2-tests.patch
new file mode 100644
index 0000000000..9e93ca875c
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel/disable-dri2-tests.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From ec91cfe7e5efdd5e1b1fbb85eea8f07b50e24c4b Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Wed, 11 Sep 2013 21:12:37 +0100
+Subject: [PATCH] test: only build DRI2 tests if DRI2 is enabled
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ test/Makefile.am | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index f51967b..18528a9 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -16,9 +16,14 @@ stress_TESTS = \
+ render-copyarea-size \
+ render-copy-alphaless \
+ mixed-stress \
++ $(NULL)
++
++if DRI2
++stress_TESTS += \
+ dri2-swap \
+ dri2-race \
+ $(NULL)
++endif
+
+ check_PROGRAMS = $(stress_TESTS)
+
+@@ -34,9 +39,14 @@ libtest_la_SOURCES = \
+ test_image.c \
+ test_log.c \
+ test_render.c \
++ $(NULL)
++
++if DRI2
++libtest_la_SOURCES += \
+ dri2.c \
+ dri2.h \
+ $(NULL)
++endif
+
+ vsync.avi: mkvsync.sh
+ ./mkvsync.sh $@
+--
+1.7.10.4
+
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.13.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.13.bb
index f26544b3c9..3e309362a6 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.13.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.13.bb
@@ -11,6 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e"
DEPENDS += "virtual/libx11 drm libpciaccess pixman"
+SRC_URI += "file://disable-dri2-tests.patch"
+
PACKAGECONFIG ??= "sna udev ${@base_contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)}"
PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,xf86driproto dri2proto"