aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-12-24 09:02:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-31 09:42:48 +0000
commit86ec57e2837465954f51fc55fce990b5ec6b1063 (patch)
tree8e5804b03de14aa3ff385fe48fc51181ab375b9b
parent38d6aacea5384cfea71d421e4404852dd01b9077 (diff)
downloadopenembedded-core-86ec57e2837465954f51fc55fce990b5ec6b1063.tar.gz
replace portmap with rpcbind.
Rpcbind has more features, like ipv6 support and nfs4 support; Redhat, Fedora, debian, Ubuntu are using rpcbind by default. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb2
-rwxr-xr-xmeta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh16
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb2
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
index 5a4a7e7cbf..84b8e76315 100644
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
# util-linux for libblkid
DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
-RDEPENDS_${PN} = "portmap"
+RDEPENDS_${PN} = "rpcbind"
RRECOMMENDS_${PN} = "kernel-module-nfsd"
PR = "r5"
diff --git a/meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh b/meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh
index 82ec7f66eb..4fffe4e808 100755
--- a/meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh
+++ b/meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh
@@ -1,7 +1,7 @@
#!/bin/sh
### BEGIN INIT INFO
# Provides: mountnfs
-# Required-Start: $local_fs $network $portmap
+# Required-Start: $local_fs $network $rpcbind
# Required-Stop:
# Default-Start: S
# Default-Stop:
@@ -17,9 +17,9 @@ test -f /etc/fstab && (
#
# Read through fstab line by line. If it is NFS, set the flag
# for mounting NFS filesystems. If any NFS partition is found and it
-# not mounted with the nolock option, we start the portmapper.
+# not mounted with the nolock option, we start the rpcbind.
#
-portmap=no
+rpcbind=no
mount_nfs=no
mount_smb=no
mount_ncp=no
@@ -45,7 +45,7 @@ do
*nolock*)
;;
*)
- portmap=yes
+ rpcbind=yes
;;
esac
fi
@@ -65,12 +65,12 @@ done
exec 0>&1
-if test "$portmap" = yes
+if test "$rpcbind" = yes
then
- if test -x /sbin/portmap
+ if test -x /usr/sbin/rpcbind
then
- echo -n "Starting portmapper... "
- start-stop-daemon --start --quiet --exec /sbin/portmap
+ echo -n "Starting rpcbind... "
+ start-stop-daemon --start --quiet --exec /usr/sbin/rpcbind
sleep 2
fi
fi
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index 4ab34bbce4..100cc88be3 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -331,7 +331,7 @@ RRECOMMENDS_packagegroup-base-cramfs = "\
#
SUMMARY_packagegroup-base-nfs = "NFS network filesystem support"
RDEPENDS_packagegroup-base-nfs = "\
- portmap"
+ rpcbind"
RRECOMMENDS_packagegroup-base-nfs = "\
kernel-module-nfs "