aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-12 17:29:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-13 17:37:58 +0100
commit7d91b44e00d6c50b7b5fbef17f2bae8e3a983a4c (patch)
tree0f04d6a2c8ff4fdb17d9f785b3461445e569e486
parentd99dac66e3e121e96c4d8a29aee846d4b8f38622 (diff)
downloadopenembedded-core-7d91b44e00d6c50b7b5fbef17f2bae8e3a983a4c.tar.gz
createrepo: drop the usage of create_wrapper
create_wrapper was previously abused to invoke the Python interpretter directly instead of relying on #! parsing, which is read into a 128 byte buffer so breaks with deep build directories. However now that we already install a "nativepython" binary into the native sysroot, use sed to change the #! line to /usr/bin/env nativepython. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-support/createrepo/createrepo_0.4.11.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/createrepo/createrepo_0.4.11.bb b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
index c977c2e6e8..523d31b82a 100644
--- a/meta/recipes-support/createrepo/createrepo_0.4.11.bb
+++ b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
@@ -35,7 +35,7 @@ do_install_append_class-native () {
for i in ${D}${datadir}/createrepo/genpkgmetadata.py \
${D}${datadir}/createrepo/modifyrepo.py \
${D}${bindir}/rpm-createsolvedb.py ; do
- create_wrapper $i ${STAGING_BINDIR_NATIVE}/python-native/python
+ sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' $i
done
create_wrapper ${D}/${bindir}/createrepo \